summaryrefslogtreecommitdiffstats
path: root/toolchain/uClibc/headers
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2012-06-30 21:44:05 +0000
committerFelix Fietkau <nbd@openwrt.org>2012-06-30 21:44:05 +0000
commitc3caa1b768728fc9daf833c55f846d6bc2362efb (patch)
tree342dfb390ad368a22b7139caa2220c45b2203fc9 /toolchain/uClibc/headers
parent59b384dabe20a4930b1c8ff4e0f48367cc080662 (diff)
downloadmaster-31e0f0ae-c3caa1b768728fc9daf833c55f846d6bc2362efb.tar.gz
master-31e0f0ae-c3caa1b768728fc9daf833c55f846d6bc2362efb.tar.bz2
master-31e0f0ae-c3caa1b768728fc9daf833c55f846d6bc2362efb.zip
uClibc: split the package into the main directory and the headers/ and utils/ subdirectories to clean up build order and fix quilt support
SVN-Revision: 32557
Diffstat (limited to 'toolchain/uClibc/headers')
-rw-r--r--toolchain/uClibc/headers/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/toolchain/uClibc/headers/Makefile b/toolchain/uClibc/headers/Makefile
new file mode 100644
index 0000000000..67a2d95c37
--- /dev/null
+++ b/toolchain/uClibc/headers/Makefile
@@ -0,0 +1,26 @@
+PATH_PREFIX:=..
+
+include ../common.mk
+
+HOST_STAMP_BUILT:=$(HOST_BUILD_DIR)/.headers_built
+HOST_STAMP_INSTALLED:=$(TOOLCHAIN_DIR)/stamp/.uclibc_headers_installed
+
+define Host/Compile
+
+endef
+
+define Host/Install
+ PATH='$(TARGET_PATH)' $(MAKE) -C $(HOST_BUILD_DIR) \
+ PREFIX="$(BUILD_DIR_TOOLCHAIN)/$(LIBC)-dev/" \
+ DEVEL_PREFIX=/ \
+ RUNTIME_PREFIX="$(BUILD_DIR_TOOLCHAIN)/$(LIBC)-dev/" \
+ HOSTCC="$(HOSTCC)" \
+ CC="$(TARGET_CC)" \
+ CPU_CFLAGS="$(TARGET_CFLAGS)" \
+ ARCH="$(CONFIG_ARCH)" \
+ pregen \
+ install_headers
+endef
+
+$(eval $(call HostBuild))
+