summaryrefslogtreecommitdiffstats
path: root/toolchain/uClibc/Makefile
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2009-10-02 00:18:16 +0000
committerNicolas Thill <nico@openwrt.org>2009-10-02 00:18:16 +0000
commitfd6e548d42075b6bea023b92544c37a03e36f4c8 (patch)
treec5fcf3ab5ef3c71522a0dc1407047faf9438f593 /toolchain/uClibc/Makefile
parent4a99a9b7e369b17939b5d1988edf1d79f66db726 (diff)
downloadmaster-31e0f0ae-fd6e548d42075b6bea023b92544c37a03e36f4c8.tar.gz
master-31e0f0ae-fd6e548d42075b6bea023b92544c37a03e36f4c8.tar.bz2
master-31e0f0ae-fd6e548d42075b6bea023b92544c37a03e36f4c8.zip
uClibc: remove absolute path linking to host libraries in libpthread.so (closes: #5601)
SVN-Revision: 17814
Diffstat (limited to 'toolchain/uClibc/Makefile')
-rw-r--r--toolchain/uClibc/Makefile18
1 files changed, 9 insertions, 9 deletions
diff --git a/toolchain/uClibc/Makefile b/toolchain/uClibc/Makefile
index 7206df2720..1d18bffb49 100644
--- a/toolchain/uClibc/Makefile
+++ b/toolchain/uClibc/Makefile
@@ -103,15 +103,15 @@ define Host/Compile
$(UCLIBC_MAKE) PREFIX="$(TOOLCHAIN_DIR)/" install_runtime install_dev
ln -sf ../../lib/libc.so.0 $(TOOLCHAIN_DIR)/usr/lib/libc.so
$(CP) $(HOST_BUILD_DIR)/libc/libc_so.a $(TOOLCHAIN_DIR)/usr/lib/
-# ( cd $(TOOLCHAIN_DIR) ; \
-# for d in lib usr/lib ; do \
-# for f in libc.so libpthread.so libgcc_s.so ; do \
-# if [ -f $$$$d/$$$$f -a ! -L $$$$d/$$$$f ] ; then \
-# $(SED) 's,/usr/lib/,,g;s,/lib/,,g' $$$$d/$$$$f ; \
-# fi \
-# done \
-# done \
-# )
+ ( cd $(TOOLCHAIN_DIR) ; \
+ for d in lib usr/lib ; do \
+ for f in libc.so libpthread.so libgcc_s.so ; do \
+ if [ -f $$$$d/$$$$f -a ! -L $$$$d/$$$$f ] ; then \
+ $(SED) 's,/usr/lib/,,g;s,/lib/,,g' $$$$d/$$$$f ; \
+ fi \
+ done \
+ done \
+ )
endef
define Host/Install