summaryrefslogtreecommitdiffstats
path: root/toolchain/uClibc/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2010-11-24 00:30:26 +0000
committerFelix Fietkau <nbd@openwrt.org>2010-11-24 00:30:26 +0000
commitf21c0cacf85b01b954a4eab07c3e5c183c4c354d (patch)
treed6605ee81da6f4378104b266294fb1288e9050ae /toolchain/uClibc/Makefile
parent0c0c1f017fc1d65ce9e16387289ca5efcd059ce0 (diff)
downloadmaster-31e0f0ae-f21c0cacf85b01b954a4eab07c3e5c183c4c354d.tar.gz
master-31e0f0ae-f21c0cacf85b01b954a4eab07c3e5c183c4c354d.tar.bz2
master-31e0f0ae-f21c0cacf85b01b954a4eab07c3e5c183c4c354d.zip
uClibc: add back a few cflags that were being overwritten, might fix a few segfauls (thx, framer99)
SVN-Revision: 24120
Diffstat (limited to 'toolchain/uClibc/Makefile')
-rw-r--r--toolchain/uClibc/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/toolchain/uClibc/Makefile b/toolchain/uClibc/Makefile
index 0df26d097f..c5dea08bb4 100644
--- a/toolchain/uClibc/Makefile
+++ b/toolchain/uClibc/Makefile
@@ -101,12 +101,17 @@ endef
define Host/Configure
endef
+CPU_CFLAGS = \
+ -funsigned-char -fno-builtin -fno-asm \
+ --std=gnu99 -ffunction-sections -fdata-sections \
+ $(TARGET_CFLAGS)
+
UCLIBC_MAKE = PATH='$(TARGET_PATH)' $(MAKE) -C $(HOST_BUILD_DIR) \
$(TARGET_CONFIGURE_OPTS) \
DEVEL_PREFIX=/ \
RUNTIME_PREFIX=/ \
HOSTCC="$(HOSTCC)" \
- CPU_CFLAGS="$(TARGET_CFLAGS)" \
+ CPU_CFLAGS="$(CPU_CFLAGS)" \
ARCH="$(CONFIG_ARCH)" \
LIBGCC="$(subst libgcc.a,libgcc_initial.a,$(shell $(TARGET_CC) -print-libgcc-file-name))" \
DOSTRIP=""