summaryrefslogtreecommitdiffstats
path: root/toolchain/uClibc/Makefile
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2009-01-21 11:45:32 +0000
committerNicolas Thill <nico@openwrt.org>2009-01-21 11:45:32 +0000
commita271aaa2dbe04f5ae79b9b5783def34b51c9cd82 (patch)
tree0d9a8c99947dad008b621549da83fc9cf0c13df8 /toolchain/uClibc/Makefile
parented4d79b529ee917418e48c3097796e46850502a1 (diff)
downloadmaster-31e0f0ae-a271aaa2dbe04f5ae79b9b5783def34b51c9cd82.tar.gz
master-31e0f0ae-a271aaa2dbe04f5ae79b9b5783def34b51c9cd82.tar.bz2
master-31e0f0ae-a271aaa2dbe04f5ae79b9b5783def34b51c9cd82.zip
add support for uClibc v0.9.30 (closes: #4271), thanks to Luigi Mantellini & Puchu!
SVN-Revision: 14130
Diffstat (limited to 'toolchain/uClibc/Makefile')
-rw-r--r--toolchain/uClibc/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/toolchain/uClibc/Makefile b/toolchain/uClibc/Makefile
index 8578ff0a15..c5771bd5ce 100644
--- a/toolchain/uClibc/Makefile
+++ b/toolchain/uClibc/Makefile
@@ -39,6 +39,12 @@ ifeq ($(PKG_VERSION),0.9.29)
endif
endif
+ifeq ($(PKG_VERSION),0.9.30)
+ ifeq ($(PKG_EXTRAVERSION),)
+ PKG_MD5SUM:=e5766e2566e0297adebebbcc0aba1f2d
+ endif
+endif
+
ifeq ($(PKG_VERSION_SNAPSHOT),y)
PATCH_DIR:=
CONFIG_DIR:=./config
@@ -132,7 +138,8 @@ define Build/Prepare
HOSTCC="$(HOSTCC)" \
CC="$(TARGET_CC)" \
CPU_CFLAGS="$(TARGET_CFLAGS)" \
- pregen install_dev;
+ pregen \
+ $(if $(CONFIG_UCLIBC_VERSION_0_9_28),install_dev,install_headers)
endef
define Build/Configure