summaryrefslogtreecommitdiffstats
path: root/toolchain/uClibc/Makefile
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2010-03-07 15:10:57 +0000
committerNicolas Thill <nico@openwrt.org>2010-03-07 15:10:57 +0000
commit44371569612a97c7dd7b8943b062862f56ffbcb1 (patch)
tree511e15dab6799dae1e1dab2b017d884f3a398017 /toolchain/uClibc/Makefile
parent4c63458e635f517355425df08b452234d06c5b1d (diff)
downloadmaster-31e0f0ae-44371569612a97c7dd7b8943b062862f56ffbcb1.tar.gz
master-31e0f0ae-44371569612a97c7dd7b8943b062862f56ffbcb1.tar.bz2
master-31e0f0ae-44371569612a97c7dd7b8943b062862f56ffbcb1.zip
uClibc: enhance debug support (closes: #6118)
SVN-Revision: 20031
Diffstat (limited to 'toolchain/uClibc/Makefile')
-rw-r--r--toolchain/uClibc/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/toolchain/uClibc/Makefile b/toolchain/uClibc/Makefile
index b94fc2e71e..25fd09f832 100644
--- a/toolchain/uClibc/Makefile
+++ b/toolchain/uClibc/Makefile
@@ -58,7 +58,10 @@ define Host/SetToolchainInfo
$(SED) 's,^\(LIBC_SO_VERSION\)=.*,\1=$(LIBC_SO_VERSION),' $(TOOLCHAIN_DIR)/info.mk
endef
-GEN_CONFIG=$(SCRIPT_DIR)/kconfig.pl -n $(if $(wildcard $(CONFIG_DIR)/common),'+' $(CONFIG_DIR)/common) ./$(CONFIG_DIR)/$(ARCH)$(if $(wildcard $(CONFIG_DIR)/$(ARCH).$(BOARD)),.$(BOARD))
+GEN_CONFIG=$(SCRIPT_DIR)/kconfig.pl -n \
+ $(if $(wildcard $(CONFIG_DIR)/common),'+' $(CONFIG_DIR)/common) \
+ $(if $(CONFIG_UCLIBC_ENABLE_DEBUG),$(if $(wildcard $(CONFIG_DIR)/debug),'+' $(CONFIG_DIR)/debug)) \
+ $(CONFIG_DIR)/$(ARCH)$(if $(wildcard $(CONFIG_DIR)/$(ARCH).$(BOARD)),.$(BOARD))
define Host/Prepare
$(call Host/SetToolchainInfo)
@@ -100,10 +103,6 @@ UCLIBC_MAKE = PATH='$(TARGET_PATH)' $(MAKE) -C $(HOST_BUILD_DIR) \
LIBGCC="$(subst libgcc.a,libgcc_initial.a,$(shell $(TARGET_CC) -print-libgcc-file-name))" \
DOSTRIP=""
-ifeq ($(CONFIG_UCLIBC_ENABLE_DEBUG),y)
- UCLIBC_MAKE += DODEBUG=y
-endif
-
define Host/Compile
$(SED) 's,^CROSS=.*,CROSS=$(TARGET_CROSS),g' $(HOST_BUILD_DIR)/Rules.mak
$(UCLIBC_MAKE) PREFIX= all