summaryrefslogtreecommitdiffstats
path: root/toolchain/uClibc/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-05-04 18:41:08 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-05-04 18:41:08 +0000
commit141925202ea2593083635bdb8d74dad0a165bb9d (patch)
tree1d1e54dce0fe941b55c914f484d62b7db30aca0e /toolchain/uClibc/Makefile
parent010c9c48e0d3a9bf178ca036de9a97a2d62b1704 (diff)
downloadmaster-31e0f0ae-141925202ea2593083635bdb8d74dad0a165bb9d.tar.gz
master-31e0f0ae-141925202ea2593083635bdb8d74dad0a165bb9d.tar.bz2
master-31e0f0ae-141925202ea2593083635bdb8d74dad0a165bb9d.zip
fix the uclibc rebuild issue which leads to unresolved symbols in libnl (and possibly other libraries)
SVN-Revision: 15599
Diffstat (limited to 'toolchain/uClibc/Makefile')
-rw-r--r--toolchain/uClibc/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/toolchain/uClibc/Makefile b/toolchain/uClibc/Makefile
index e8407fb9c5..b55796b40f 100644
--- a/toolchain/uClibc/Makefile
+++ b/toolchain/uClibc/Makefile
@@ -88,12 +88,13 @@ endef
define Host/Configure
endef
-UCLIBC_MAKE := PATH=$(TARGET_PATH) $(MAKE) -C $(HOST_BUILD_DIR) \
+UCLIBC_MAKE = PATH=$(TARGET_PATH) $(MAKE) -C $(HOST_BUILD_DIR) \
$(TARGET_CONFIGURE_OPTS) \
DEVEL_PREFIX=/usr/ \
RUNTIME_PREFIX=/ \
HOSTCC="$(HOSTCC)" \
CPU_CFLAGS="$(TARGET_CFLAGS)" \
+ LIBGCC="$(subst libgcc.a,libgcc_initial.a,$(shell $(TARGET_CC) -print-libgcc-file-name))" \
DOSTRIP=""
define Host/Compile