summaryrefslogtreecommitdiffstats
path: root/toolchain/musl
diff options
context:
space:
mode:
authorMatteo Croce <rootkit85@yahoo.it>2015-06-25 10:14:22 +0000
committerMatteo Croce <rootkit85@yahoo.it>2015-06-25 10:14:22 +0000
commitc37d7a7e8f35e2f0ffa3a5dac89cea138f5ca193 (patch)
treeb414f916ffb0ff0a03ee24b4f3327da954b17797 /toolchain/musl
parent9bdae8fc1ef7b4477bd998ee8272cff66c83fff7 (diff)
downloadmaster-31e0f0ae-c37d7a7e8f35e2f0ffa3a5dac89cea138f5ca193.tar.gz
master-31e0f0ae-c37d7a7e8f35e2f0ffa3a5dac89cea138f5ca193.tar.bz2
master-31e0f0ae-c37d7a7e8f35e2f0ffa3a5dac89cea138f5ca193.zip
fix mklibs with musl
crate a relative symlink to libc.so because make wildcard function ignores broken symlinks SVN-Revision: 46123
Diffstat (limited to 'toolchain/musl')
-rw-r--r--toolchain/musl/patches/300-relative.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/toolchain/musl/patches/300-relative.patch b/toolchain/musl/patches/300-relative.patch
new file mode 100644
index 0000000000..dc7d167635
--- /dev/null
+++ b/toolchain/musl/patches/300-relative.patch
@@ -0,0 +1,11 @@
+--- a/Makefile
++++ b/Makefile
+@@ -180,7 +180,7 @@ $(DESTDIR)$(includedir)/%: include/%
+ $(INSTALL) -D -m 644 $< $@
+
+ $(DESTDIR)$(LDSO_PATHNAME): $(DESTDIR)$(libdir)/libc.so
+- $(INSTALL) -D -l $(libdir)/libc.so $@ || true
++ $(INSTALL) -D -l libc.so $@ || true
+
+ install-libs: $(ALL_LIBS:lib/%=$(DESTDIR)$(libdir)/%) $(if $(SHARED_LIBS),$(DESTDIR)$(LDSO_PATHNAME),)
+