summaryrefslogtreecommitdiffstats
path: root/toolchain/musl/patches/200-add_libssp_nonshared.patch
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2016-01-30 20:15:11 +0000
committerFelix Fietkau <nbd@openwrt.org>2016-01-30 20:15:11 +0000
commited95e47f072caaeffdc48a78718cfc08fe89f690 (patch)
treeaae48b7885b6b76d105627d533ef4dec7b769705 /toolchain/musl/patches/200-add_libssp_nonshared.patch
parentb046040bd6f323b214dbeee9767db7644cf3a6bd (diff)
downloadmaster-31e0f0ae-ed95e47f072caaeffdc48a78718cfc08fe89f690.tar.gz
master-31e0f0ae-ed95e47f072caaeffdc48a78718cfc08fe89f690.tar.bz2
master-31e0f0ae-ed95e47f072caaeffdc48a78718cfc08fe89f690.zip
musl: update to the latest git version, fixes TLS issues
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 48574
Diffstat (limited to 'toolchain/musl/patches/200-add_libssp_nonshared.patch')
-rw-r--r--toolchain/musl/patches/200-add_libssp_nonshared.patch18
1 files changed, 9 insertions, 9 deletions
diff --git a/toolchain/musl/patches/200-add_libssp_nonshared.patch b/toolchain/musl/patches/200-add_libssp_nonshared.patch
index 0b97b346f8..f6758cdae8 100644
--- a/toolchain/musl/patches/200-add_libssp_nonshared.patch
+++ b/toolchain/musl/patches/200-add_libssp_nonshared.patch
@@ -12,7 +12,7 @@ Signed-off-by: Steven Barth <steven@midlink.org>
--- a/Makefile
+++ b/Makefile
-@@ -56,7 +56,7 @@ CRT_LIBS = lib/crt1.o lib/Scrt1.o lib/rc
+@@ -60,7 +60,7 @@ CRT_LIBS = lib/crt1.o lib/Scrt1.o lib/rc
STATIC_LIBS = lib/libc.a
SHARED_LIBS = lib/libc.so
TOOL_LIBS = lib/musl-gcc.specs
@@ -21,18 +21,18 @@ Signed-off-by: Steven Barth <steven@midlink.org>
ALL_TOOLS = obj/musl-gcc
WRAPCC_GCC = gcc
-@@ -117,7 +117,8 @@ NOSSP_SRCS = $(wildcard crt/*.c) \
- src/env/__libc_start_main.c src/env/__init_tls.c \
- src/thread/__set_thread_area.c src/env/__stack_chk_fail.c \
- src/string/memset.c src/string/memcpy.c \
-- src/ldso/dlstart.c src/ldso/dynlink.c
-+ src/ldso/dlstart.c src/ldso/dynlink.c \
+@@ -123,7 +123,8 @@ NOSSP_SRCS = $(wildcard crt/*.c) \
+ src/thread/__set_thread_area.c src/thread/$(ARCH)/__set_thread_area.c \
+ src/string/memset.c src/string/$(ARCH)/memset.c \
+ src/string/memcpy.c src/string/$(ARCH)/memcpy.c \
+- ldso/dlstart.c ldso/dynlink.c
++ ldso/dlstart.c ldso/dynlink.c \
+ src/libssp_nonshared/__stack_chk_fail_local.c
$(NOSSP_SRCS:%.c=obj/%.o) $(NOSSP_SRCS:%.c=obj/%.lo): CFLAGS_ALL += $(CFLAGS_NOSSP)
$(CRT_LIBS:lib/%=obj/crt/%): CFLAGS_ALL += -DCRT
-@@ -161,6 +162,11 @@ lib/libc.a: $(OBJS)
- $(AR) rc $@ $(OBJS)
+@@ -167,6 +168,11 @@ lib/libc.a: $(AOBJS)
+ $(AR) rc $@ $(AOBJS)
$(RANLIB) $@
+lib/libssp_nonshared.a: obj/src/libssp_nonshared/__stack_chk_fail_local.o