summaryrefslogtreecommitdiffstats
path: root/toolchain/musl/patches-0.9.10/000-install_portability.patch
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2013-05-09 20:34:21 +0000
committerFelix Fietkau <nbd@openwrt.org>2013-05-09 20:34:21 +0000
commita424aa612396a0105889664486b68ab0a3e91b2e (patch)
tree3ded921cf225a0a9e3f0046867bae239db6d6fdc /toolchain/musl/patches-0.9.10/000-install_portability.patch
parent7054f27c6f6e4e2e3ffcd4c77ef4fc0b433fb11d (diff)
downloadmaster-31e0f0ae-a424aa612396a0105889664486b68ab0a3e91b2e.tar.gz
master-31e0f0ae-a424aa612396a0105889664486b68ab0a3e91b2e.tar.bz2
master-31e0f0ae-a424aa612396a0105889664486b68ab0a3e91b2e.zip
toolchain/musl: add version 0.9.10
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 36591
Diffstat (limited to 'toolchain/musl/patches-0.9.10/000-install_portability.patch')
-rw-r--r--toolchain/musl/patches-0.9.10/000-install_portability.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/toolchain/musl/patches-0.9.10/000-install_portability.patch b/toolchain/musl/patches-0.9.10/000-install_portability.patch
new file mode 100644
index 0000000000..3e018c67e9
--- /dev/null
+++ b/toolchain/musl/patches-0.9.10/000-install_portability.patch
@@ -0,0 +1,27 @@
+--- a/Makefile
++++ b/Makefile
+@@ -116,16 +116,20 @@ tools/musl-gcc: config.mak
+ chmod +x $@
+
+ $(DESTDIR)$(bindir)/%: tools/%
+- install -D $< $@
++ mkdir -p $(dir $@)
++ install $< $@
+
+ $(DESTDIR)$(libdir)/%.so: lib/%.so
+- install -D -m 755 $< $@
++ mkdir -p $(dir $@)
++ install -m 755 $< $@
+
+ $(DESTDIR)$(libdir)/%: lib/%
+- install -D -m 644 $< $@
++ mkdir -p $(dir $@)
++ install -m 644 $< $@
+
+ $(DESTDIR)$(includedir)/%: include/%
+- install -D -m 644 $< $@
++ mkdir -p $(dir $@)
++ install -m 644 $< $@
+
+ $(DESTDIR)$(LDSO_PATHNAME): $(DESTDIR)$(syslibdir)
+ ln -sf $(libdir)/libc.so $@ || true