summaryrefslogtreecommitdiffstats
path: root/toolchain/llvm/patches/100-darwin_arch_auto.patch
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-10-10 19:25:48 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-10-10 19:25:48 +0000
commit215ccb66e6abdaed0a41582d6b8c40ffa340eea7 (patch)
treee8ecd7ecc708bda6515831abaffbcb8d9ee65d5f /toolchain/llvm/patches/100-darwin_arch_auto.patch
parentb49cdabd4ae2c0239dc12eda5e1b7a21b9c2e5dc (diff)
downloadmaster-31e0f0ae-215ccb66e6abdaed0a41582d6b8c40ffa340eea7.tar.gz
master-31e0f0ae-215ccb66e6abdaed0a41582d6b8c40ffa340eea7.tar.bz2
master-31e0f0ae-215ccb66e6abdaed0a41582d6b8c40ffa340eea7.zip
gcc: add llvm-gcc and llvm from trunk (does not successfully compile a target yet, but gets close)
SVN-Revision: 18019
Diffstat (limited to 'toolchain/llvm/patches/100-darwin_arch_auto.patch')
-rw-r--r--toolchain/llvm/patches/100-darwin_arch_auto.patch19
1 files changed, 19 insertions, 0 deletions
diff --git a/toolchain/llvm/patches/100-darwin_arch_auto.patch b/toolchain/llvm/patches/100-darwin_arch_auto.patch
new file mode 100644
index 0000000000..a48e131219
--- /dev/null
+++ b/toolchain/llvm/patches/100-darwin_arch_auto.patch
@@ -0,0 +1,19 @@
+--- a/Makefile.rules
++++ b/Makefile.rules
+@@ -618,16 +618,6 @@ ifdef UNIVERSAL
+
+ # Building universal cannot compute dependencies automatically.
+ DISABLE_AUTO_DEPENDENCIES=1
+-else
+- ifeq ($(TARGET_OS),Darwin)
+- ifeq ($(ARCH),x86_64)
+- TargetCommonOpts = -m64
+- else
+- ifeq ($(ARCH),x86)
+- TargetCommonOpts = -m32
+- endif
+- endif
+- endif
+ endif
+
+ ifeq ($(HOST_OS),SunOS)