summaryrefslogtreecommitdiffstats
path: root/toolchain/glibc
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2009-01-21 11:58:17 +0000
committerNicolas Thill <nico@openwrt.org>2009-01-21 11:58:17 +0000
commitec7b663c86839b2ddc42b27fc472dfc1fbf0ebb8 (patch)
tree1aac0de5ad5bfbab6dc9c8965a1fafbbfe774e43 /toolchain/glibc
parenta271aaa2dbe04f5ae79b9b5783def34b51c9cd82 (diff)
downloadmaster-31e0f0ae-ec7b663c86839b2ddc42b27fc472dfc1fbf0ebb8.tar.gz
master-31e0f0ae-ec7b663c86839b2ddc42b27fc472dfc1fbf0ebb8.tar.bz2
master-31e0f0ae-ec7b663c86839b2ddc42b27fc472dfc1fbf0ebb8.zip
add support for gcc v4.3.1 & v4.3.2 (closes: #3479), thanks to Luigi Mantellini!
SVN-Revision: 14131
Diffstat (limited to 'toolchain/glibc')
-rw-r--r--toolchain/glibc/patches/2.6.1/101-binutils_2_19.patch12
-rw-r--r--toolchain/glibc/patches/2.6.1/102-gcc_4_3.patch38
-rw-r--r--toolchain/glibc/patches/2.7/101-binutils_2_19.patch12
-rw-r--r--toolchain/glibc/patches/2.7/102-gcc_4_3.patch38
4 files changed, 100 insertions, 0 deletions
diff --git a/toolchain/glibc/patches/2.6.1/101-binutils_2_19.patch b/toolchain/glibc/patches/2.6.1/101-binutils_2_19.patch
new file mode 100644
index 0000000000..cc1b7401aa
--- /dev/null
+++ b/toolchain/glibc/patches/2.6.1/101-binutils_2_19.patch
@@ -0,0 +1,12 @@
+diff -ruN glibc-2.6.1-old/sysdeps/i386/fpu/ftestexcept.c glibc-2.6.1-new/sysdeps/i386/fpu/ftestexcept.c
+--- glibc-2.6.1-old/sysdeps/i386/fpu/ftestexcept.c 2004-03-05 11:14:48.000000000 +0100
++++ glibc-2.6.1-new/sysdeps/i386/fpu/ftestexcept.c 2009-01-21 03:29:56.000000000 +0100
+@@ -26,7 +26,7 @@
+ int
+ fetestexcept (int excepts)
+ {
+- int temp;
++ short temp;
+ int xtemp = 0;
+
+ /* Get current exceptions. */
diff --git a/toolchain/glibc/patches/2.6.1/102-gcc_4_3.patch b/toolchain/glibc/patches/2.6.1/102-gcc_4_3.patch
new file mode 100644
index 0000000000..86042f5660
--- /dev/null
+++ b/toolchain/glibc/patches/2.6.1/102-gcc_4_3.patch
@@ -0,0 +1,38 @@
+http://sourceware.org/bugzilla/show_bug.cgi?id=5442
+
+diff -ruN glibc-2.6.1-old/configure.in glibc-2.6.1-new/configure.in
+--- glibc-2.6.1-old/configure.in 2007-03-20 13:11:23.000000000 +0100
++++ glibc-2.6.1-new/configure.in 2009-01-21 01:09:16.000000000 +0100
+@@ -911,8 +911,12 @@
+ # header directory and add that to the list. NOTE: Only does the right
+ # thing on a system that doesn't need fixincludes. (Not presently a problem.)
+ if test -n "$sysheaders"; then
+- ccheaders=`$CC -print-file-name=include`
+- SYSINCLUDES="-nostdinc -isystem $ccheaders \
++ SYSINCLUDES=-nostdinc
++ for d in include include-fixed; do
++ i=`$CC -print-file-name="$d"` && test "x$i" != x && test "x$i" != "x$d" &&
++ SYSINCLUDES="$SYSINCLUDES -isystem $i"
++ done
++ SYSINCLUDES="$SYSINCLUDES \
+ -isystem `echo $sysheaders | sed 's/:/ -isystem /g'`"
+ if test -n "$CXX"; then
+ cxxversion=`$CXX -dumpversion 2>&AS_MESSAGE_LOG_FD` &&
+diff -ruN glibc-2.6.1-old/configure glibc-2.6.1-new/configure
+--- glibc-2.6.1-old/configure 2007-07-31 15:46:12.000000000 +0200
++++ glibc-2.6.1-new/configure 2009-01-21 01:09:13.000000000 +0100
+@@ -4562,8 +4562,12 @@
+ # header directory and add that to the list. NOTE: Only does the right
+ # thing on a system that doesn't need fixincludes. (Not presently a problem.)
+ if test -n "$sysheaders"; then
+- ccheaders=`$CC -print-file-name=include`
+- SYSINCLUDES="-nostdinc -isystem $ccheaders \
++ SYSINCLUDES=-nostdinc
++ for d in include include-fixed; do
++ i=`$CC -print-file-name="$d"` && test "x$i" != "x$d" &&
++ SYSINCLUDES="$SYSINCLUDES -isystem $i"
++ done
++ SYSINCLUDES="$SYSINCLUDES \
+ -isystem `echo $sysheaders | sed 's/:/ -isystem /g'`"
+ if test -n "$CXX"; then
+ cxxversion=`$CXX -dumpversion 2>&5` &&
diff --git a/toolchain/glibc/patches/2.7/101-binutils_2_19.patch b/toolchain/glibc/patches/2.7/101-binutils_2_19.patch
new file mode 100644
index 0000000000..5971112045
--- /dev/null
+++ b/toolchain/glibc/patches/2.7/101-binutils_2_19.patch
@@ -0,0 +1,12 @@
+diff -ruN glibc-2.7-old/sysdeps/i386/fpu/ftestexcept.c glibc-2.7-new/sysdeps/i386/fpu/ftestexcept.c
+--- glibc-2.7-old/sysdeps/i386/fpu/ftestexcept.c 2004-03-05 11:14:48.000000000 +0100
++++ glibc-2.7-new/sysdeps/i386/fpu/ftestexcept.c 2009-01-21 03:33:43.000000000 +0100
+@@ -26,7 +26,7 @@
+ int
+ fetestexcept (int excepts)
+ {
+- int temp;
++ short temp;
+ int xtemp = 0;
+
+ /* Get current exceptions. */
diff --git a/toolchain/glibc/patches/2.7/102-gcc_4_3.patch b/toolchain/glibc/patches/2.7/102-gcc_4_3.patch
new file mode 100644
index 0000000000..2ed3f548a9
--- /dev/null
+++ b/toolchain/glibc/patches/2.7/102-gcc_4_3.patch
@@ -0,0 +1,38 @@
+http://sourceware.org/bugzilla/show_bug.cgi?id=5442
+
+diff -ruN glibc-2.7-old/configure.in glibc-2.7-new/configure.in
+--- glibc-2.7-old/configure.in 2007-06-08 05:16:36.000000000 +0200
++++ glibc-2.7-new/configure.in 2009-01-21 01:12:42.000000000 +0100
+@@ -911,8 +911,12 @@
+ # header directory and add that to the list. NOTE: Only does the right
+ # thing on a system that doesn't need fixincludes. (Not presently a problem.)
+ if test -n "$sysheaders"; then
+- ccheaders=`$CC -print-file-name=include`
+- SYSINCLUDES="-nostdinc -isystem $ccheaders \
++ SYSINCLUDES=-nostdinc
++ for d in include include-fixed; do
++ i=`$CC -print-file-name="$d"` && test "x$i" != x && test "x$i" != "x$d" &&
++ SYSINCLUDES="$SYSINCLUDES -isystem $i"
++ done
++ SYSINCLUDES="$SYSINCLUDES \
+ -isystem `echo $sysheaders | sed 's/:/ -isystem /g'`"
+ if test -n "$CXX"; then
+ cxxversion=`$CXX -dumpversion 2>&AS_MESSAGE_LOG_FD` &&
+diff -ruN glibc-2.7-old/configure glibc-2.7-new/configure
+--- glibc-2.7-old/configure 2007-10-18 13:22:23.000000000 +0200
++++ glibc-2.7-new/configure 2009-01-21 01:12:45.000000000 +0100
+@@ -5062,8 +5062,12 @@
+ # header directory and add that to the list. NOTE: Only does the right
+ # thing on a system that doesn't need fixincludes. (Not presently a problem.)
+ if test -n "$sysheaders"; then
+- ccheaders=`$CC -print-file-name=include`
+- SYSINCLUDES="-nostdinc -isystem $ccheaders \
++ SYSINCLUDES=-nostdinc
++ for d in include include-fixed; do
++ i=`$CC -print-file-name="$d"` && test "x$i" != "x$d" &&
++ SYSINCLUDES="$SYSINCLUDES -isystem $i"
++ done
++ SYSINCLUDES="$SYSINCLUDES \
+ -isystem `echo $sysheaders | sed 's/:/ -isystem /g'`"
+ if test -n "$CXX"; then
+ cxxversion=`$CXX -dumpversion 2>&5` &&