summaryrefslogtreecommitdiffstats
path: root/toolchain/glibc
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2010-08-19 12:49:51 +0000
committerFelix Fietkau <nbd@openwrt.org>2010-08-19 12:49:51 +0000
commit62c174067616a911ef77a8cf02a6cc2220e534ec (patch)
tree30ea6c074ef3e3c343c672c2fcc492453ed252e2 /toolchain/glibc
parentd9e0d5705ab187ff024067049f1077f95074a6c6 (diff)
downloadmaster-31e0f0ae-62c174067616a911ef77a8cf02a6cc2220e534ec.tar.gz
master-31e0f0ae-62c174067616a911ef77a8cf02a6cc2220e534ec.tar.bz2
master-31e0f0ae-62c174067616a911ef77a8cf02a6cc2220e534ec.zip
toolchain: fix the sysroot mess by getting rid of $(TOOLCHAIN_DIR)/usr and moving it back to $(TOOLCHAIN_DIR), this change makes the toolchain relocatable again, which should fix the SDK
SVN-Revision: 22723
Diffstat (limited to 'toolchain/glibc')
-rw-r--r--toolchain/glibc/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/toolchain/glibc/Makefile b/toolchain/glibc/Makefile
index 5d56d4b98a..abd1c57077 100644
--- a/toolchain/glibc/Makefile
+++ b/toolchain/glibc/Makefile
@@ -57,10 +57,10 @@ GLIBC_CONFIGURE:= \
libc_cv_386_tls=yes \
libc_cv_slibdir="/lib" \
$(HOST_BUILD_DIR)/configure \
- --prefix=/usr \
+ --prefix=/ \
--build=$(GNU_HOST_NAME) \
--host=$(REAL_GNU_TARGET_NAME) \
- --with-headers="$(TOOLCHAIN_DIR)/usr/include" \
+ --with-headers="$(TOOLCHAIN_DIR)/include" \
$(if $(CONFIG_mips64)$(CONFIG_mips64el), --enable-kernel="2.6.0") \
--disable-debug \
--disable-profile \
@@ -111,11 +111,11 @@ define Stage1/Install
cross-compiling=yes \
install_root="$(BUILD_DIR_TOOLCHAIN)/$(LIBC)-dev" \
install-headers
- [ -f $(BUILD_DIR_TOOLCHAIN)/$(LIBC)-dev/usr/include/bits/stdio_lim.h ] || \
+ [ -f $(BUILD_DIR_TOOLCHAIN)/$(LIBC)-dev/include/bits/stdio_lim.h ] || \
$(CP) $(HOST_BUILD_DIR1)/bits/stdio_lim.h \
- $(BUILD_DIR_TOOLCHAIN)/$(LIBC)-dev/usr/include/bits/stdio_lim.h
- [ -f $(BUILD_DIR_TOOLCHAIN)/$(LIBC)-dev/usr/include/gnu/stubs.h ] || \
- touch $(BUILD_DIR_TOOLCHAIN)/$(LIBC)-dev/usr/include/gnu/stubs.h
+ $(BUILD_DIR_TOOLCHAIN)/$(LIBC)-dev/include/bits/stdio_lim.h
+ [ -f $(BUILD_DIR_TOOLCHAIN)/$(LIBC)-dev/include/gnu/stubs.h ] || \
+ touch $(BUILD_DIR_TOOLCHAIN)/$(LIBC)-dev/include/gnu/stubs.h
endef
define Stage2/Configure