summaryrefslogtreecommitdiffstats
path: root/toolchain/glibc
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-04-18 17:03:55 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-04-18 17:03:55 +0000
commit56164a5815346ed801c1fd8885023f55c19b29ff (patch)
treed5f46ef620e54d7b0ff56c98fed8ad25895d6bb7 /toolchain/glibc
parent24aedf82810f1abcdd345741ab7a97adea43ad1c (diff)
downloadmaster-31e0f0ae-56164a5815346ed801c1fd8885023f55c19b29ff.tar.gz
master-31e0f0ae-56164a5815346ed801c1fd8885023f55c19b29ff.tar.bz2
master-31e0f0ae-56164a5815346ed801c1fd8885023f55c19b29ff.zip
add a modified version of the mips64 patch from #4603
SVN-Revision: 15249
Diffstat (limited to 'toolchain/glibc')
-rw-r--r--toolchain/glibc/Config.version6
-rw-r--r--toolchain/glibc/Makefile1
2 files changed, 4 insertions, 3 deletions
diff --git a/toolchain/glibc/Config.version b/toolchain/glibc/Config.version
index d68eeea8a9..1debf0c040 100644
--- a/toolchain/glibc/Config.version
+++ b/toolchain/glibc/Config.version
@@ -9,7 +9,7 @@ config GLIBC_VERSION
config GLIBC_PORTS
bool
depends on USE_GLIBC
- default y if GLIBC_VERSION_2_3_6 && (arm || armeb || mips || mipsel)
- default y if GLIBC_VERSION_2_6_1 && (arm || armeb || mips || mipsel || powerpc)
- default y if GLIBC_VERSION_2_7 && (arm || armeb || mips || mipsel || powerpc)
+ default y if GLIBC_VERSION_2_3_6 && (arm || armeb || mips || mipsel || mips64 || mips64el)
+ default y if GLIBC_VERSION_2_6_1 && (arm || armeb || mips || mipsel || mips64 || mips64el || powerpc)
+ default y if GLIBC_VERSION_2_7 && (arm || armeb || mips || mipsel || mips64 || mips64el || powerpc)
default n
diff --git a/toolchain/glibc/Makefile b/toolchain/glibc/Makefile
index d014cacded..054d891303 100644
--- a/toolchain/glibc/Makefile
+++ b/toolchain/glibc/Makefile
@@ -57,6 +57,7 @@ GLIBC_CONFIGURE:= \
--build=$(GNU_HOST_NAME) \
--host=$(REAL_GNU_TARGET_NAME) \
--with-headers="$(TOOLCHAIN_DIR)/usr/include" \
+ $(if $(CONFIG_mips64)$(CONFIG_mips64el), --enable-kernel="2.6.0") \
--disable-debug \
--disable-profile \
--enable-add-ons="$(GLIBC_ADD_ONS)" \