summaryrefslogtreecommitdiffstats
path: root/toolchain/glibc
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2009-02-03 21:25:48 +0000
committerNicolas Thill <nico@openwrt.org>2009-02-03 21:25:48 +0000
commit33a0eb3613da33aafd435eb4ed1e985944f42c78 (patch)
tree73adfaa44c084674b08e2c82942d3b3dfa330d9d /toolchain/glibc
parent1716050f0c274d198abebf2b9e21fb9f754c199a (diff)
downloadmaster-31e0f0ae-33a0eb3613da33aafd435eb4ed1e985944f42c78.tar.gz
master-31e0f0ae-33a0eb3613da33aafd435eb4ed1e985944f42c78.tar.bz2
master-31e0f0ae-33a0eb3613da33aafd435eb4ed1e985944f42c78.zip
cosmetic & coherency fixes
SVN-Revision: 14397
Diffstat (limited to 'toolchain/glibc')
-rw-r--r--toolchain/glibc/Makefile13
1 files changed, 6 insertions, 7 deletions
diff --git a/toolchain/glibc/Makefile b/toolchain/glibc/Makefile
index fd6acc46b8..f808615cd4 100644
--- a/toolchain/glibc/Makefile
+++ b/toolchain/glibc/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2006-2008 OpenWrt.org
+# Copyright (C) 2006-2009 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -21,7 +21,6 @@ endif
PKG_SOURCE_URL:=@GNU/glibc/
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_CAT:=bzcat
PATCH_DIR:=./patches/$(PKG_VERSION)
@@ -51,7 +50,7 @@ endif
# http://sourceware.org/bugzilla/show_bug.cgi?id=5203
GLIBC_CFLAGS:=$(subst -Os,-O2,$(TARGET_CFLAGS))
-GLIBC_CONFIGURE_COMMON:= \
+GLIBC_CONFIGURE:= \
BUILD_CC="$(HOSTCC)" \
$(TARGET_CONFIGURE_OPTS) \
CFLAGS="$(GLIBC_CFLAGS)" \
@@ -70,20 +69,20 @@ GLIBC_CONFIGURE_COMMON:= \
--without-cvs \
ifeq ($(CONFIG_SOFT_FLOAT),)
- GLIBC_CONFIGURE_COMMON+= \
+ GLIBC_CONFIGURE+= \
--with-fp
else
- GLIBC_CONFIGURE_COMMON+= \
+ GLIBC_CONFIGURE+= \
--without-fp
endif
GLIBC_CONFIGURE_STAGE1:= \
- $(GLIBC_CONFIGURE_COMMON) \
+ $(GLIBC_CONFIGURE) \
--disable-sanity-checks \
--enable-hacker-mode \
GLIBC_CONFIGURE_STAGE2:= \
- $(GLIBC_CONFIGURE_COMMON) \
+ $(GLIBC_CONFIGURE) \
GLIBC_MAKE:= \
$(MAKE) \