summaryrefslogtreecommitdiffstats
path: root/toolchain/glibc/patches
diff options
context:
space:
mode:
authorMirko Vogt <mirko@openwrt.org>2011-06-17 22:51:24 +0000
committerMirko Vogt <mirko@openwrt.org>2011-06-17 22:51:24 +0000
commit74fecd036611e881eeace99d31017e4b70bac70c (patch)
tree19cc91047e9ea9667bec1f9477b8e6ddb72c9569 /toolchain/glibc/patches
parent8d48672c109beb1a9cf515aea7c99c10af85f672 (diff)
downloadmaster-31e0f0ae-74fecd036611e881eeace99d31017e4b70bac70c.tar.gz
master-31e0f0ae-74fecd036611e881eeace99d31017e4b70bac70c.tar.bz2
master-31e0f0ae-74fecd036611e881eeace99d31017e4b70bac70c.zip
fix glibc to work with all versions of binutils, fixes #7133 - thanks to marek siller
SVN-Revision: 27210
Diffstat (limited to 'toolchain/glibc/patches')
-rw-r--r--toolchain/glibc/patches/2.7/103-binutils_2_20.patch15
-rw-r--r--toolchain/glibc/patches/2.7/104-binutils_2_20.patch20
2 files changed, 35 insertions, 0 deletions
diff --git a/toolchain/glibc/patches/2.7/103-binutils_2_20.patch b/toolchain/glibc/patches/2.7/103-binutils_2_20.patch
new file mode 100644
index 0000000000..66d44ad571
--- /dev/null
+++ b/toolchain/glibc/patches/2.7/103-binutils_2_20.patch
@@ -0,0 +1,15 @@
+--- glibc-2.7-old/configure.in 2010-08-05 15:41:13.379279183 +0200
++++ glibc-2.7-new/configure.in 2010-08-05 15:46:30.236940604 +0200
+@@ -842,10 +842,10 @@
+ # Accept binutils 2.13 or newer.
+ AC_CHECK_PROG_VER(AS, $AS, --version,
+ [GNU assembler.* \([0-9]*\.[0-9.]*\)],
+- [2.1[3-9]*], AS=: critic_missing="$critic_missing as")
++ [2.1[3-9]*|2.1[0-9][0-9]*|2.[2-9]*]|[3-9].*, AS=: critic_missing="$critic_missing as")
+ AC_CHECK_PROG_VER(LD, $LD, --version,
+ [GNU ld.* \([0-9][0-9]*\.[0-9.]*\)],
+- [2.1[3-9]*], LD=: critic_missing="$critic_missing ld")
++ [2.1[3-9]*|2.1[0-9][0-9]*|2.[2-9]*]|[3-9].*, LD=: critic_missing="$critic_missing ld")
+
+ # We need the physical current working directory. We cannot use the
+ # "pwd -P" shell builtin since that's not portable. Instead we try to
diff --git a/toolchain/glibc/patches/2.7/104-binutils_2_20.patch b/toolchain/glibc/patches/2.7/104-binutils_2_20.patch
new file mode 100644
index 0000000000..4e6ca5cf6c
--- /dev/null
+++ b/toolchain/glibc/patches/2.7/104-binutils_2_20.patch
@@ -0,0 +1,20 @@
+--- glibc-2.7-old/configure 2010-08-05 16:21:23.899880380 +0200
++++ glibc-2.7-new/configure 2010-08-05 16:26:25.269006172 +0200
+@@ -4527,7 +4527,7 @@
+ ac_prog_version=`$AS --version 2>&1 | sed -n 's/^.*GNU assembler.* \([0-9]*\.[0-9.]*\).*$/\1/p'`
+ case $ac_prog_version in
+ '') ac_prog_version="v. ?.??, bad"; ac_verc_fail=yes;;
+- 2.1[3-9]*)
++ 2.1[3-9]*|2.1[0-9][0-9]*|2.[2-9]*|[3-9].*)
+ ac_prog_version="$ac_prog_version, ok"; ac_verc_fail=no;;
+ *) ac_prog_version="$ac_prog_version, bad"; ac_verc_fail=yes;;
+
+@@ -4590,7 +4590,7 @@
+ ac_prog_version=`$LD --version 2>&1 | sed -n 's/^.*GNU ld.* \([0-9][0-9]*\.[0-9.]*\).*$/\1/p'`
+ case $ac_prog_version in
+ '') ac_prog_version="v. ?.??, bad"; ac_verc_fail=yes;;
+- 2.1[3-9]*)
++ 2.1[3-9]*|2.1[0-9][0-9]*|2.[2-9]*|[3-9].*)
+ ac_prog_version="$ac_prog_version, ok"; ac_verc_fail=no;;
+ *) ac_prog_version="$ac_prog_version, bad"; ac_verc_fail=yes;;
+