summaryrefslogtreecommitdiffstats
path: root/toolchain/glibc/headers
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-03-12 19:50:57 +0000
committerJohn Crispin <john@openwrt.org>2015-03-12 19:50:57 +0000
commit3e2f57835342074a90843077c1c63c88a42e6217 (patch)
tree666eb809bad8689d3e992696cd44ea8efa233eda /toolchain/glibc/headers
parenteff1859f8e75d7d7cc3d07d2bcb5952ab214b8a0 (diff)
downloadmaster-31e0f0ae-3e2f57835342074a90843077c1c63c88a42e6217.tar.gz
master-31e0f0ae-3e2f57835342074a90843077c1c63c88a42e6217.tar.bz2
master-31e0f0ae-3e2f57835342074a90843077c1c63c88a42e6217.zip
toolchain: The glorious return of glibc, ver 2.21
It's the eglibc packaging with a bit of spit-polishing. And testing. :-) [blogic: merged glibc and eglibc into 1 and made eglibc a glibc variant] Signed-off-by: Jeff Waugh <jdub@bethesignal.org> Signed-off-by: John Crispin <blogic@openwrt.org> SVN-Revision: 44701
Diffstat (limited to 'toolchain/glibc/headers')
-rw-r--r--toolchain/glibc/headers/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/toolchain/glibc/headers/Makefile b/toolchain/glibc/headers/Makefile
new file mode 100644
index 0000000000..f9f411b1f0
--- /dev/null
+++ b/toolchain/glibc/headers/Makefile
@@ -0,0 +1,27 @@
+PATH_PREFIX:=..
+VARIANT:=headers
+
+include ../common.mk
+
+define Host/Compile
+
+endef
+
+define Host/Install
+ $(call Host/SetToolchainInfo)
+ mkdir -p $(BUILD_DIR_TOOLCHAIN)/$(LIBC)-dev/{include,lib}
+ $(MAKE) -C $(CUR_BUILD_DIR) \
+ BUILD_CFLAGS="$(HOST_CFLAGS)" \
+ install_root="$(BUILD_DIR_TOOLCHAIN)/$(LIBC)-dev" \
+ install-bootstrap-headers=yes \
+ install-headers
+ $(MAKE) -C $(CUR_BUILD_DIR) \
+ csu/subdir_lib
+ ( cd $(CUR_BUILD_DIR); \
+ $(CP) csu/crt1.o csu/crti.o csu/crtn.o $(BUILD_DIR_TOOLCHAIN)/$(LIBC)-dev/lib/ \
+ )
+ $(TARGET_CC) -nostdlib -nostartfiles -shared -x c /dev/null \
+ -o $(BUILD_DIR_TOOLCHAIN)/$(LIBC)-dev/lib/libc.so
+endef
+
+$(eval $(call HostBuild))