summaryrefslogtreecommitdiffstats
path: root/toolchain/glibc/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-03-12 19:50:57 +0000
committerJohn Crispin <john@openwrt.org>2015-03-12 19:50:57 +0000
commit3e2f57835342074a90843077c1c63c88a42e6217 (patch)
tree666eb809bad8689d3e992696cd44ea8efa233eda /toolchain/glibc/Makefile
parenteff1859f8e75d7d7cc3d07d2bcb5952ab214b8a0 (diff)
downloadmaster-31e0f0ae-3e2f57835342074a90843077c1c63c88a42e6217.tar.gz
master-31e0f0ae-3e2f57835342074a90843077c1c63c88a42e6217.tar.bz2
master-31e0f0ae-3e2f57835342074a90843077c1c63c88a42e6217.zip
toolchain: The glorious return of glibc, ver 2.21
It's the eglibc packaging with a bit of spit-polishing. And testing. :-) [blogic: merged glibc and eglibc into 1 and made eglibc a glibc variant] Signed-off-by: Jeff Waugh <jdub@bethesignal.org> Signed-off-by: John Crispin <blogic@openwrt.org> SVN-Revision: 44701
Diffstat (limited to 'toolchain/glibc/Makefile')
-rw-r--r--toolchain/glibc/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/toolchain/glibc/Makefile b/toolchain/glibc/Makefile
new file mode 100644
index 0000000000..f880db81ed
--- /dev/null
+++ b/toolchain/glibc/Makefile
@@ -0,0 +1,31 @@
+PATH_PREFIX := .
+VARIANT:=final
+HOST_BUILD_PARALLEL:=0
+
+include ./common.mk
+
+define Host/Compile
+ $(MAKE) -C $(CUR_BUILD_DIR) \
+ PARALLELMFLAGS="$(HOST_JOBS)" \
+ BUILD_CFLAGS="$(HOST_CFLAGS)" \
+ all
+endef
+
+define Host/Install
+ $(call Host/SetToolchainInfo)
+ $(MAKE) -C $(CUR_BUILD_DIR) \
+ BUILD_CFLAGS="$(HOST_CFLAGS)" \
+ install_root="$(TOOLCHAIN_DIR)" \
+ install
+ ( cd $(TOOLCHAIN_DIR) ; \
+ for d in lib usr/lib ; do \
+ for f in libc.so libpthread.so libgcc_s.so ; do \
+ if [ -f $$$$d/$$$$f -a ! -L $$$$d/$$$$f ] ; then \
+ $(SED) 's,/usr/lib/,,g;s,/lib/,,g' $$$$d/$$$$f ; \
+ fi \
+ done \
+ done \
+ )
+endef
+
+$(eval $(call HostBuild))