summaryrefslogtreecommitdiffstats
path: root/toolchain/glibc/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2012-02-12 16:12:01 +0000
committerFelix Fietkau <nbd@openwrt.org>2012-02-12 16:12:01 +0000
commit07488ef93d4c2cff5e981dca1bec71747bebc5b0 (patch)
treed8396705821e83118ef0b211a07b0f7a7ffc6669 /toolchain/glibc/Makefile
parentfd74a50df75b6f1288f217e45046032a379e4221 (diff)
downloadmaster-31e0f0ae-07488ef93d4c2cff5e981dca1bec71747bebc5b0.tar.gz
master-31e0f0ae-07488ef93d4c2cff5e981dca1bec71747bebc5b0.tar.bz2
master-31e0f0ae-07488ef93d4c2cff5e981dca1bec71747bebc5b0.zip
glibc: remove all previous (ancient) versions, add 2.14 (partially based on a patch and testing by WillieNL)
SVN-Revision: 30478
Diffstat (limited to 'toolchain/glibc/Makefile')
-rw-r--r--toolchain/glibc/Makefile16
1 files changed, 3 insertions, 13 deletions
diff --git a/toolchain/glibc/Makefile b/toolchain/glibc/Makefile
index 789ae842d6..caf4b088ea 100644
--- a/toolchain/glibc/Makefile
+++ b/toolchain/glibc/Makefile
@@ -9,20 +9,11 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=glibc
PKG_VERSION:=$(call qstrip,$(CONFIG_GLIBC_VERSION))
-ifeq ($(PKG_VERSION),2.3.6)
- PKG_MD5SUM:=bfdce99f82d6dbcb64b7f11c05d6bc96
-endif
-ifeq ($(PKG_VERSION),2.4)
- PKG_MD5SUM:=7e9a88dcd41fbc53801dbe5bdacaf245
-endif
-ifeq ($(PKG_VERSION),2.6.1)
- PKG_MD5SUM:=11cf6d3fc86dbe0890b8d00372eb6286
-endif
-ifeq ($(PKG_VERSION),2.7)
- PKG_MD5SUM:=065c5952b439deba40083ccd67bcc8f7
+ifeq ($(PKG_VERSION),2.14)
+ PKG_MD5SUM:=1588cc22e796c296223744895ebc4cef
endif
-PKG_SOURCE_URL:=@GNU/glibc/
+PKG_SOURCE_URL:=@GNU/glibc
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PATCH_DIR:=./patches/$(PKG_VERSION)
@@ -87,7 +78,6 @@ GLIBC_CONFIGURE_STAGE2:= \
GLIBC_MAKE:= \
$(MAKE) \
-
define Host/SetToolchainInfo
$(SED) 's,^\(LIBC_TYPE\)=.*,\1=$(PKG_NAME),' $(TOOLCHAIN_DIR)/info.mk
$(SED) 's,^\(LIBC_URL\)=.*,\1=http://www.gnu.org/software/libc/,' $(TOOLCHAIN_DIR)/info.mk