summaryrefslogtreecommitdiffstats
path: root/toolchain/gdb
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-01-13 02:15:43 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-01-13 02:15:43 +0000
commitb8aa79853d94080142d1b155b0d0b06f74a36179 (patch)
treeb52d168197f8cc12c5e19b69d4ae09aecf4028e3 /toolchain/gdb
parentff55a797174df57a6e806a64b291b40212465abc (diff)
downloadmaster-31e0f0ae-b8aa79853d94080142d1b155b0d0b06f74a36179.tar.gz
master-31e0f0ae-b8aa79853d94080142d1b155b0d0b06f74a36179.tar.bz2
master-31e0f0ae-b8aa79853d94080142d1b155b0d0b06f74a36179.zip
fix gdb compile
SVN-Revision: 14015
Diffstat (limited to 'toolchain/gdb')
-rw-r--r--toolchain/gdb/Makefile5
-rw-r--r--toolchain/gdb/patches/910-missing_header.patch11
2 files changed, 14 insertions, 2 deletions
diff --git a/toolchain/gdb/Makefile b/toolchain/gdb/Makefile
index e4d8235c62..be3e423a1c 100644
--- a/toolchain/gdb/Makefile
+++ b/toolchain/gdb/Makefile
@@ -22,6 +22,7 @@ include $(INCLUDE_DIR)/host-build.mk
define Build/Configure
(cd $(PKG_BUILD_DIR); \
gdb_cv_func_sigsetjmp=yes \
+ CFLAGS="-O2" \
$(PKG_BUILD_DIR)/configure \
--prefix=$(TOOLCHAIN_DIR)/usr \
--build=$(GNU_HOST_NAME) \
@@ -48,8 +49,8 @@ endef
define Build/Clean
rm -rf \
- $(PKG_BUILD_DIR)
- $(TOOLCHAIN_DIR)/usr/bin/$(TARGET_CROSS)gdb
+ $(PKG_BUILD_DIR) \
+ $(TOOLCHAIN_DIR)/usr/bin/$(TARGET_CROSS)gdb \
$(TOOLCHAIN_DIR)/usr/bin/$(GNU_TARGET_NAME)-gdb
endef
diff --git a/toolchain/gdb/patches/910-missing_header.patch b/toolchain/gdb/patches/910-missing_header.patch
new file mode 100644
index 0000000000..e3a5cc70bd
--- /dev/null
+++ b/toolchain/gdb/patches/910-missing_header.patch
@@ -0,0 +1,11 @@
+--- a/gdb/inferior.h
++++ b/gdb/inferior.h
+@@ -21,6 +21,8 @@
+ Foundation, Inc., 59 Temple Place - Suite 330,
+ Boston, MA 02111-1307, USA. */
+
++#include <sys/types.h>
++
+ #if !defined (INFERIOR_H)
+ #define INFERIOR_H 1
+