summaryrefslogtreecommitdiffstats
path: root/toolchain/gcc
diff options
context:
space:
mode:
authorAlexey Brodkin <Alexey.Brodkin@synopsys.com>2016-05-19 08:20:33 +0300
committerFelix Fietkau <nbd@nbd.name>2016-05-19 19:29:44 +0200
commitd354bfde174514973309e788e11c286f1667c2f5 (patch)
treec71bdb107387fb9c9aedce9b93f8cabbf5ab2378 /toolchain/gcc
parent8d105653b13eb5f56764c8e02f307f4d28a6a3a7 (diff)
downloadmaster-31e0f0ae-d354bfde174514973309e788e11c286f1667c2f5.tar.gz
master-31e0f0ae-d354bfde174514973309e788e11c286f1667c2f5.tar.bz2
master-31e0f0ae-d354bfde174514973309e788e11c286f1667c2f5.zip
toolchain: Bump ARC tools to arc-2016.03
This change switches ARC tools to the most recent arc-2016.03 version. ARC GNU tools of version arc-2016.03 bring some quite significant changes like: * Binutils v2.26+ (upstream commit id 202ac19 with additional ARC * patches) * GCC v4.8.5 * GDB 7.10 More about changes, improvements and fixes could be found here: https://github.com/foss-for-synopsys-dwc-arc-processors/toolchain/releases/tag/arc-2016.03 Signed-off-by: Alexey Brodkin <abrodkin@synopsys.com>
Diffstat (limited to 'toolchain/gcc')
-rw-r--r--toolchain/gcc/Config.version2
-rw-r--r--toolchain/gcc/common.mk8
-rw-r--r--toolchain/gcc/patches/arc-2016.03/001-revert_register_mode_search.patch (renamed from toolchain/gcc/patches/arc-2015.06/001-revert_register_mode_search.patch)0
-rw-r--r--toolchain/gcc/patches/arc-2016.03/002-weak_data_fix.patch (renamed from toolchain/gcc/patches/arc-2015.06/002-weak_data_fix.patch)0
-rw-r--r--toolchain/gcc/patches/arc-2016.03/003-universal_initializer.patch (renamed from toolchain/gcc/patches/arc-2015.06/003-universal_initializer.patch)0
-rw-r--r--toolchain/gcc/patches/arc-2016.03/004-case_insensitive.patch (renamed from toolchain/gcc/patches/arc-2015.06/004-case_insensitive.patch)0
-rw-r--r--toolchain/gcc/patches/arc-2016.03/010-documentation.patch (renamed from toolchain/gcc/patches/arc-2015.06/010-documentation.patch)0
-rw-r--r--toolchain/gcc/patches/arc-2016.03/020-no-plt-backport.patch (renamed from toolchain/gcc/patches/arc-2015.06/020-no-plt-backport.patch)0
-rw-r--r--toolchain/gcc/patches/arc-2016.03/100-uclibc-conf.patch (renamed from toolchain/gcc/patches/arc-2015.06/100-uclibc-conf.patch)0
-rw-r--r--toolchain/gcc/patches/arc-2016.03/210-disable_libsanitizer_off_t_check.patch (renamed from toolchain/gcc/patches/arc-2015.06/210-disable_libsanitizer_off_t_check.patch)0
-rw-r--r--toolchain/gcc/patches/arc-2016.03/800-arc-disablelibgmon.patch (renamed from toolchain/gcc/patches/arc-2015.06/800-arc-disablelibgmon.patch)0
-rw-r--r--toolchain/gcc/patches/arc-2016.03/820-libgcc_pic.patch (renamed from toolchain/gcc/patches/arc-2015.06/820-libgcc_pic.patch)0
-rw-r--r--toolchain/gcc/patches/arc-2016.03/850-use_shared_libgcc.patch (renamed from toolchain/gcc/patches/arc-2015.06/850-use_shared_libgcc.patch)0
-rw-r--r--toolchain/gcc/patches/arc-2016.03/851-libgcc_no_compat.patch (renamed from toolchain/gcc/patches/arc-2015.06/851-libgcc_no_compat.patch)0
-rw-r--r--toolchain/gcc/patches/arc-2016.03/860-use_eh_frame.patch (renamed from toolchain/gcc/patches/arc-2015.06/860-use_eh_frame.patch)0
-rw-r--r--toolchain/gcc/patches/arc-2016.03/870-ppc_no_crtsavres.patch (renamed from toolchain/gcc/patches/arc-2015.06/870-ppc_no_crtsavres.patch)0
-rw-r--r--toolchain/gcc/patches/arc-2016.03/880-no_java_section.patch (renamed from toolchain/gcc/patches/arc-2015.06/880-no_java_section.patch)0
-rw-r--r--toolchain/gcc/patches/arc-2016.03/910-mbsd_multi.patch (renamed from toolchain/gcc/patches/arc-2015.06/910-mbsd_multi.patch)0
-rw-r--r--toolchain/gcc/patches/arc-2016.03/920-specs_nonfatal_getenv.patch (renamed from toolchain/gcc/patches/arc-2015.06/920-specs_nonfatal_getenv.patch)0
-rw-r--r--toolchain/gcc/patches/arc-2016.03/940-no-clobber-stamp-bits.patch (renamed from toolchain/gcc/patches/arc-2015.06/940-no-clobber-stamp-bits.patch)0
20 files changed, 5 insertions, 5 deletions
diff --git a/toolchain/gcc/Config.version b/toolchain/gcc/Config.version
index 5d393c54d0..f9e8c47c6f 100644
--- a/toolchain/gcc/Config.version
+++ b/toolchain/gcc/Config.version
@@ -5,7 +5,7 @@ config GCC_VERSION_4_8_ARC
config GCC_VERSION
string
default "4.8-linaro" if GCC_VERSION_4_8_LINARO
- default "arc-2015.06" if GCC_VERSION_4_8_ARC
+ default "arc-2016.03" if GCC_VERSION_4_8_ARC
default "5.3.0"
config GCC_VERSION_4_8
diff --git a/toolchain/gcc/common.mk b/toolchain/gcc/common.mk
index e6b5c8ea4b..c3546f545b 100644
--- a/toolchain/gcc/common.mk
+++ b/toolchain/gcc/common.mk
@@ -33,11 +33,11 @@ ifeq ($(PKG_VERSION),5.3.0)
endif
ifneq ($(CONFIG_GCC_VERSION_4_8_ARC),)
- PKG_VERSION:=4.8.4
- PKG_SOURCE_URL:=https://github.com/foss-for-synopsys-dwc-arc-processors/gcc/archive/arc-2015.06
+ PKG_VERSION:=4.8.5
+ PKG_SOURCE_URL:=https://github.com/foss-for-synopsys-dwc-arc-processors/gcc/archive/arc-2016.03
PKG_SOURCE:=$(PKG_NAME)-$(GCC_VERSION).tar.gz
- PKG_MD5SUM:=25007ebb02a5f6c32532b103bb5984a0
- PKG_REV:=2015.06
+ PKG_MD5SUM:=ca59c8140d6efd07b97a18869bddbb53
+ PKG_REV:=2016.03
GCC_DIR:=gcc-arc-$(PKG_REV)
HOST_BUILD_DIR = $(BUILD_DIR_HOST)/$(PKG_NAME)-$(GCC_VERSION)
endif
diff --git a/toolchain/gcc/patches/arc-2015.06/001-revert_register_mode_search.patch b/toolchain/gcc/patches/arc-2016.03/001-revert_register_mode_search.patch
index 162d651394..162d651394 100644
--- a/toolchain/gcc/patches/arc-2015.06/001-revert_register_mode_search.patch
+++ b/toolchain/gcc/patches/arc-2016.03/001-revert_register_mode_search.patch
diff --git a/toolchain/gcc/patches/arc-2015.06/002-weak_data_fix.patch b/toolchain/gcc/patches/arc-2016.03/002-weak_data_fix.patch
index a740b4ce9e..a740b4ce9e 100644
--- a/toolchain/gcc/patches/arc-2015.06/002-weak_data_fix.patch
+++ b/toolchain/gcc/patches/arc-2016.03/002-weak_data_fix.patch
diff --git a/toolchain/gcc/patches/arc-2015.06/003-universal_initializer.patch b/toolchain/gcc/patches/arc-2016.03/003-universal_initializer.patch
index 1b9a5b3081..1b9a5b3081 100644
--- a/toolchain/gcc/patches/arc-2015.06/003-universal_initializer.patch
+++ b/toolchain/gcc/patches/arc-2016.03/003-universal_initializer.patch
diff --git a/toolchain/gcc/patches/arc-2015.06/004-case_insensitive.patch b/toolchain/gcc/patches/arc-2016.03/004-case_insensitive.patch
index b3d2dbe291..b3d2dbe291 100644
--- a/toolchain/gcc/patches/arc-2015.06/004-case_insensitive.patch
+++ b/toolchain/gcc/patches/arc-2016.03/004-case_insensitive.patch
diff --git a/toolchain/gcc/patches/arc-2015.06/010-documentation.patch b/toolchain/gcc/patches/arc-2016.03/010-documentation.patch
index 5548069d1b..5548069d1b 100644
--- a/toolchain/gcc/patches/arc-2015.06/010-documentation.patch
+++ b/toolchain/gcc/patches/arc-2016.03/010-documentation.patch
diff --git a/toolchain/gcc/patches/arc-2015.06/020-no-plt-backport.patch b/toolchain/gcc/patches/arc-2016.03/020-no-plt-backport.patch
index b225376865..b225376865 100644
--- a/toolchain/gcc/patches/arc-2015.06/020-no-plt-backport.patch
+++ b/toolchain/gcc/patches/arc-2016.03/020-no-plt-backport.patch
diff --git a/toolchain/gcc/patches/arc-2015.06/100-uclibc-conf.patch b/toolchain/gcc/patches/arc-2016.03/100-uclibc-conf.patch
index ff9ad94f62..ff9ad94f62 100644
--- a/toolchain/gcc/patches/arc-2015.06/100-uclibc-conf.patch
+++ b/toolchain/gcc/patches/arc-2016.03/100-uclibc-conf.patch
diff --git a/toolchain/gcc/patches/arc-2015.06/210-disable_libsanitizer_off_t_check.patch b/toolchain/gcc/patches/arc-2016.03/210-disable_libsanitizer_off_t_check.patch
index 56084692a1..56084692a1 100644
--- a/toolchain/gcc/patches/arc-2015.06/210-disable_libsanitizer_off_t_check.patch
+++ b/toolchain/gcc/patches/arc-2016.03/210-disable_libsanitizer_off_t_check.patch
diff --git a/toolchain/gcc/patches/arc-2015.06/800-arc-disablelibgmon.patch b/toolchain/gcc/patches/arc-2016.03/800-arc-disablelibgmon.patch
index 612883c98c..612883c98c 100644
--- a/toolchain/gcc/patches/arc-2015.06/800-arc-disablelibgmon.patch
+++ b/toolchain/gcc/patches/arc-2016.03/800-arc-disablelibgmon.patch
diff --git a/toolchain/gcc/patches/arc-2015.06/820-libgcc_pic.patch b/toolchain/gcc/patches/arc-2016.03/820-libgcc_pic.patch
index 7a0ac7353e..7a0ac7353e 100644
--- a/toolchain/gcc/patches/arc-2015.06/820-libgcc_pic.patch
+++ b/toolchain/gcc/patches/arc-2016.03/820-libgcc_pic.patch
diff --git a/toolchain/gcc/patches/arc-2015.06/850-use_shared_libgcc.patch b/toolchain/gcc/patches/arc-2016.03/850-use_shared_libgcc.patch
index 6934bc97f6..6934bc97f6 100644
--- a/toolchain/gcc/patches/arc-2015.06/850-use_shared_libgcc.patch
+++ b/toolchain/gcc/patches/arc-2016.03/850-use_shared_libgcc.patch
diff --git a/toolchain/gcc/patches/arc-2015.06/851-libgcc_no_compat.patch b/toolchain/gcc/patches/arc-2016.03/851-libgcc_no_compat.patch
index 80c3476841..80c3476841 100644
--- a/toolchain/gcc/patches/arc-2015.06/851-libgcc_no_compat.patch
+++ b/toolchain/gcc/patches/arc-2016.03/851-libgcc_no_compat.patch
diff --git a/toolchain/gcc/patches/arc-2015.06/860-use_eh_frame.patch b/toolchain/gcc/patches/arc-2016.03/860-use_eh_frame.patch
index 1ac83fe4dc..1ac83fe4dc 100644
--- a/toolchain/gcc/patches/arc-2015.06/860-use_eh_frame.patch
+++ b/toolchain/gcc/patches/arc-2016.03/860-use_eh_frame.patch
diff --git a/toolchain/gcc/patches/arc-2015.06/870-ppc_no_crtsavres.patch b/toolchain/gcc/patches/arc-2016.03/870-ppc_no_crtsavres.patch
index 4b7fcbd5e1..4b7fcbd5e1 100644
--- a/toolchain/gcc/patches/arc-2015.06/870-ppc_no_crtsavres.patch
+++ b/toolchain/gcc/patches/arc-2016.03/870-ppc_no_crtsavres.patch
diff --git a/toolchain/gcc/patches/arc-2015.06/880-no_java_section.patch b/toolchain/gcc/patches/arc-2016.03/880-no_java_section.patch
index def6c9f4a0..def6c9f4a0 100644
--- a/toolchain/gcc/patches/arc-2015.06/880-no_java_section.patch
+++ b/toolchain/gcc/patches/arc-2016.03/880-no_java_section.patch
diff --git a/toolchain/gcc/patches/arc-2015.06/910-mbsd_multi.patch b/toolchain/gcc/patches/arc-2016.03/910-mbsd_multi.patch
index 5387f8e86f..5387f8e86f 100644
--- a/toolchain/gcc/patches/arc-2015.06/910-mbsd_multi.patch
+++ b/toolchain/gcc/patches/arc-2016.03/910-mbsd_multi.patch
diff --git a/toolchain/gcc/patches/arc-2015.06/920-specs_nonfatal_getenv.patch b/toolchain/gcc/patches/arc-2016.03/920-specs_nonfatal_getenv.patch
index 09768f525b..09768f525b 100644
--- a/toolchain/gcc/patches/arc-2015.06/920-specs_nonfatal_getenv.patch
+++ b/toolchain/gcc/patches/arc-2016.03/920-specs_nonfatal_getenv.patch
diff --git a/toolchain/gcc/patches/arc-2015.06/940-no-clobber-stamp-bits.patch b/toolchain/gcc/patches/arc-2016.03/940-no-clobber-stamp-bits.patch
index dbecef2d57..dbecef2d57 100644
--- a/toolchain/gcc/patches/arc-2015.06/940-no-clobber-stamp-bits.patch
+++ b/toolchain/gcc/patches/arc-2016.03/940-no-clobber-stamp-bits.patch