summaryrefslogtreecommitdiffstats
path: root/toolchain/gcc
diff options
context:
space:
mode:
authorSteven Barth <cyrus@openwrt.org>2015-06-20 17:37:20 +0000
committerSteven Barth <cyrus@openwrt.org>2015-06-20 17:37:20 +0000
commitcfdadd3e1d1402a02c19eedb9910fece5b9917c7 (patch)
tree33365cb0ef6c47f0c479eb90355cc304d731ea47 /toolchain/gcc
parentfc5f02410f27de8b2b97a8edccb859773094591e (diff)
downloadmaster-31e0f0ae-cfdadd3e1d1402a02c19eedb9910fece5b9917c7.tar.gz
master-31e0f0ae-cfdadd3e1d1402a02c19eedb9910fece5b9917c7.tar.bz2
master-31e0f0ae-cfdadd3e1d1402a02c19eedb9910fece5b9917c7.zip
gcc: musl comes with its own SSP, so use it instead of libssp
Signed-off-by: Steven Barth <steven@midlink.org> SVN-Revision: 46071
Diffstat (limited to 'toolchain/gcc')
-rw-r--r--toolchain/gcc/final/Makefile4
-rw-r--r--toolchain/gcc/patches/4.8-linaro/030-always-link-ssp-noshared.patch11
2 files changed, 15 insertions, 0 deletions
diff --git a/toolchain/gcc/final/Makefile b/toolchain/gcc/final/Makefile
index 3fb5ccf83f..1212d145ab 100644
--- a/toolchain/gcc/final/Makefile
+++ b/toolchain/gcc/final/Makefile
@@ -16,6 +16,10 @@ ifneq ($(CONFIG_GCC_VERSION_4_5)$(CONFIG_GCC_VERSION_4_6),)
--with-libelf=$(TOPDIR)/staging_dir/host
endif
+ifdef CONFIG_USE_MUSL
+ GCC_MAKE += gcc_cv_libc_provides_ssp=yes
+endif
+
ifneq ($(CONFIG_SJLJ_EXCEPTIONS),)
GCC_CONFIGURE += \
--enable-sjlj-exceptions
diff --git a/toolchain/gcc/patches/4.8-linaro/030-always-link-ssp-noshared.patch b/toolchain/gcc/patches/4.8-linaro/030-always-link-ssp-noshared.patch
new file mode 100644
index 0000000000..1208e73029
--- /dev/null
+++ b/toolchain/gcc/patches/4.8-linaro/030-always-link-ssp-noshared.patch
@@ -0,0 +1,11 @@
+--- gcc-4.7.4.org/gcc/gcc.c
++++ gcc-4.7.4/gcc/gcc.c
+@@ -603,7 +603,7 @@
+
+ #ifndef LINK_SSP_SPEC
+ #ifdef TARGET_LIBC_PROVIDES_SSP
+-#define LINK_SSP_SPEC "%{fstack-protector:}"
++#define LINK_SSP_SPEC "%{fstack-protector|fstack-protector-all:-lssp_nonshared}"
+ #else
+ #define LINK_SSP_SPEC "%{fstack-protector|fstack-protector-all:-lssp_nonshared -lssp}"
+ #endif