summaryrefslogtreecommitdiffstats
path: root/toolchain/gcc
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2016-07-07 14:12:30 +0200
committerFelix Fietkau <nbd@nbd.name>2016-07-07 15:13:40 +0200
commit74c9b9cfeb0e7cd045b969474a9bcd9ab38bd7d2 (patch)
treeb51b7445b93c69cee641e7cdf0643f6bc18f1853 /toolchain/gcc
parent1692c71564ef4084feb0df30f04d292b52e8f976 (diff)
downloadmaster-31e0f0ae-74c9b9cfeb0e7cd045b969474a9bcd9ab38bd7d2.tar.gz
master-31e0f0ae-74c9b9cfeb0e7cd045b969474a9bcd9ab38bd7d2.tar.bz2
master-31e0f0ae-74c9b9cfeb0e7cd045b969474a9bcd9ab38bd7d2.zip
toolchain: skip gcc/minimal for musl
No extra libc header build step is done, so no extra toolchain is needed for preparing it. This saves a significant amount of build time and disk space Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'toolchain/gcc')
-rw-r--r--toolchain/gcc/common.mk26
-rw-r--r--toolchain/gcc/initial/Makefile2
-rw-r--r--toolchain/gcc/minimal/Makefile19
3 files changed, 25 insertions, 22 deletions
diff --git a/toolchain/gcc/common.mk b/toolchain/gcc/common.mk
index eab143cbc6..9bc849152b 100644
--- a/toolchain/gcc/common.mk
+++ b/toolchain/gcc/common.mk
@@ -170,10 +170,30 @@ GCC_MAKE:= \
CFLAGS_FOR_TARGET="$(TARGET_CFLAGS)" \
CXXFLAGS_FOR_TARGET="$(TARGET_CFLAGS)"
-define Host/Prepare
- mkdir -p $(GCC_BUILD_DIR)
+define Host/SetToolchainInfo
+ $(SED) 's,TARGET_CROSS=.*,TARGET_CROSS=$(REAL_GNU_TARGET_NAME)-,' $(TOOLCHAIN_DIR)/info.mk
+ $(SED) 's,GCC_VERSION=.*,GCC_VERSION=$(GCC_VERSION),' $(TOOLCHAIN_DIR)/info.mk
endef
+ifneq ($(GCC_PREPARE),)
+ define Host/Prepare
+ $(call Host/SetToolchainInfo)
+ $(call Host/Prepare/Default)
+ ln -snf $(GCC_DIR) $(BUILD_DIR_TOOLCHAIN)/$(PKG_NAME)
+ $(CP) $(SCRIPT_DIR)/config.{guess,sub} $(HOST_SOURCE_DIR)/
+ $(SED) 's,^MULTILIB_OSDIRNAMES,# MULTILIB_OSDIRNAMES,' $(HOST_SOURCE_DIR)/gcc/config/*/t-*
+ $(SED) 'd' $(HOST_SOURCE_DIR)/gcc/DEV-PHASE
+ $(SED) 's, DATESTAMP,,' $(HOST_SOURCE_DIR)/gcc/version.c
+ #(cd $(HOST_SOURCE_DIR)/libstdc++-v3; autoconf;);
+ $(SED) 's,gcc_no_link=yes,gcc_no_link=no,' $(HOST_SOURCE_DIR)/libstdc++-v3/configure
+ mkdir -p $(GCC_BUILD_DIR)
+ endef
+else
+ define Host/Prepare
+ mkdir -p $(GCC_BUILD_DIR)
+ endef
+endif
+
define Host/Configure
(cd $(GCC_BUILD_DIR) && rm -f config.cache; \
$(GCC_CONFIGURE) \
@@ -181,7 +201,7 @@ define Host/Configure
endef
define Host/Clean
- rm -rf \
+ rm -rf $(if $(GCC_PREPARE),$(HOST_SOURCE_DIR)) \
$(STAGING_DIR_HOST)/stamp/.gcc_* \
$(STAGING_DIR_HOST)/stamp/.binutils_* \
$(GCC_BUILD_DIR) \
diff --git a/toolchain/gcc/initial/Makefile b/toolchain/gcc/initial/Makefile
index f0c65b528c..1ed548436e 100644
--- a/toolchain/gcc/initial/Makefile
+++ b/toolchain/gcc/initial/Makefile
@@ -1,4 +1,5 @@
GCC_VARIANT:=initial
+GCC_PREPARE=$(CONFIG_USE_MUSL)
include ../common.mk
@@ -10,7 +11,6 @@ GCC_CONFIGURE += \
--disable-threads \
define Host/Compile
- $(CP) $(BUILD_DIR_TOOLCHAIN)/linux-dev/* $(BUILD_DIR_TOOLCHAIN)/$(LIBC)-dev/
+$(GCC_MAKE) $(HOST_JOBS) -C $(GCC_BUILD_DIR) \
all-build-libiberty \
all-gcc \
diff --git a/toolchain/gcc/minimal/Makefile b/toolchain/gcc/minimal/Makefile
index 0344e1a7ec..31d6f675ab 100644
--- a/toolchain/gcc/minimal/Makefile
+++ b/toolchain/gcc/minimal/Makefile
@@ -1,4 +1,5 @@
GCC_VARIANT:=minimal
+GCC_PREPARE=$(if $(CONFIG_USE_MUSL),,1)
include ../common.mk
@@ -11,24 +12,6 @@ GCC_CONFIGURE += \
--disable-shared \
--disable-threads
-define Host/SetToolchainInfo
- $(SED) 's,TARGET_CROSS=.*,TARGET_CROSS=$(REAL_GNU_TARGET_NAME)-,' $(TOOLCHAIN_DIR)/info.mk
- $(SED) 's,GCC_VERSION=.*,GCC_VERSION=$(GCC_VERSION),' $(TOOLCHAIN_DIR)/info.mk
-endef
-
-define Host/Prepare
- $(call Host/SetToolchainInfo)
- $(call Host/Prepare/Default)
- ln -snf $(GCC_DIR) $(BUILD_DIR_TOOLCHAIN)/$(PKG_NAME)
- $(CP) $(SCRIPT_DIR)/config.{guess,sub} $(HOST_BUILD_DIR)/
- $(SED) 's,^MULTILIB_OSDIRNAMES,# MULTILIB_OSDIRNAMES,' $(HOST_BUILD_DIR)/gcc/config/*/t-*
- $(SED) 'd' $(HOST_BUILD_DIR)/gcc/DEV-PHASE
- $(SED) 's, DATESTAMP,,' $(HOST_BUILD_DIR)/gcc/version.c
- #(cd $(HOST_BUILD_DIR)/libstdc++-v3; autoconf;);
- $(SED) 's,gcc_no_link=yes,gcc_no_link=no,' $(HOST_BUILD_DIR)/libstdc++-v3/configure
- mkdir -p $(GCC_BUILD_DIR)
-endef
-
define Host/Compile
+$(GCC_MAKE) $(HOST_JOBS) -C $(GCC_BUILD_DIR) all-gcc all-target-libgcc
endef