summaryrefslogtreecommitdiffstats
path: root/toolchain/gcc
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2011-02-25 16:52:25 +0000
committerImre Kaloz <kaloz@openwrt.org>2011-02-25 16:52:25 +0000
commita3989e3dbd80248789ee379538e6de22c1d47d0e (patch)
treed3dd71642bc0aec3dd68339e121b0537762962bd /toolchain/gcc
parent5a8a9a0e23f1467eaeaef475a8bea0542e9ecad8 (diff)
downloadmaster-31e0f0ae-a3989e3dbd80248789ee379538e6de22c1d47d0e.tar.gz
master-31e0f0ae-a3989e3dbd80248789ee379538e6de22c1d47d0e.tar.bz2
master-31e0f0ae-a3989e3dbd80248789ee379538e6de22c1d47d0e.zip
We use different toolchain directories for different ARM archs, so we should set the default arch of gcc to reflect this.
This enables EABI support for armv4 CPUs. Signed-off-by: Jochen Friedrich <jochen@scram.de> SVN-Revision: 25705
Diffstat (limited to 'toolchain/gcc')
-rw-r--r--toolchain/gcc/common.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/toolchain/gcc/common.mk b/toolchain/gcc/common.mk
index 0f22e41021..888cf7a1e5 100644
--- a/toolchain/gcc/common.mk
+++ b/toolchain/gcc/common.mk
@@ -167,6 +167,10 @@ ifdef CONFIG_powerpc
TARGET_CFLAGS := $(patsubst -Os,-O2,$(TARGET_CFLAGS))
endif
+ifneq ($(GCC_ARCH),)
+ GCC_CONFIGURE+= --with-arch=$(GCC_ARCH)
+endif
+
GCC_MAKE:= \
export SHELL="$(BASH)"; \
$(MAKE) $(TOOLCHAIN_JOBS) \