summaryrefslogtreecommitdiffstats
path: root/toolchain/gcc
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2016-02-18 08:22:17 +0000
committerJohn Crispin <john@openwrt.org>2016-02-18 08:22:17 +0000
commit7b821a5ae882cb0c70fd9d09ec9d5952985951dc (patch)
treeea5ce1cda7bc5f967859c6f85947ba857f241fcf /toolchain/gcc
parent7a29f7c22d0d13f51411282d7294aec1862e235f (diff)
downloadmaster-31e0f0ae-7b821a5ae882cb0c70fd9d09ec9d5952985951dc.tar.gz
master-31e0f0ae-7b821a5ae882cb0c70fd9d09ec9d5952985951dc.tar.bz2
master-31e0f0ae-7b821a5ae882cb0c70fd9d09ec9d5952985951dc.zip
toolchain: add support of ARCv2 architecture
This change adds support of ARC ISAv2 processors in OpenWRT toolchain. In general gcc for ARC may compile code for both ISA versions simultaneously but libgcc will be built only for default architecture that's why it's necessary to specify --with-cpu on gcc configuration. As for uClibc we need to use different configurations for different ARC ISAs. Signed-off-by: Alexey Brodkin <abrodkin@synopsys.com> Cc: Felix Fietkau <nbd@openwrt.org> Cc: Jo-Philipp Wich <jow@openwrt.org> Cc: Jonas Gorski <jogo@openwrt.org> SVN-Revision: 48739
Diffstat (limited to 'toolchain/gcc')
-rw-r--r--toolchain/gcc/common.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/toolchain/gcc/common.mk b/toolchain/gcc/common.mk
index 2912f8f612..6ac5a46f2d 100644
--- a/toolchain/gcc/common.mk
+++ b/toolchain/gcc/common.mk
@@ -111,6 +111,7 @@ GCC_CONFIGURE:= \
$(call qstrip,$(CONFIG_EXTRA_GCC_CONFIG_OPTIONS)) \
$(if $(CONFIG_mips64)$(CONFIG_mips64el),--with-arch=mips64 \
--with-abi=$(call qstrip,$(CONFIG_MIPS64_ABI))) \
+ $(if $(CONFIG_arc),--with-cpu=$(CONFIG_CPU_TYPE)) \
--with-gmp=$(TOPDIR)/staging_dir/host \
--with-mpfr=$(TOPDIR)/staging_dir/host \
--with-mpc=$(TOPDIR)/staging_dir/host \