summaryrefslogtreecommitdiffstats
path: root/toolchain/gcc
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2014-10-20 11:42:59 +0000
committerFelix Fietkau <nbd@openwrt.org>2014-10-20 11:42:59 +0000
commit20e7ccc3a2bc09194b308b959f44c92648accdf4 (patch)
tree5b36935639471a6a16de7a1b06fa0847ad7ff532 /toolchain/gcc
parentb52651a66ea7ef40f121d748126ef35c2f6e789c (diff)
downloadmaster-31e0f0ae-20e7ccc3a2bc09194b308b959f44c92648accdf4.tar.gz
master-31e0f0ae-20e7ccc3a2bc09194b308b959f44c92648accdf4.tar.bz2
master-31e0f0ae-20e7ccc3a2bc09194b308b959f44c92648accdf4.zip
gcc: update 4.9 to linaro 2014.10
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 43003
Diffstat (limited to 'toolchain/gcc')
-rw-r--r--toolchain/gcc/common.mk6
-rw-r--r--toolchain/gcc/patches/4.9-linaro/020-fix_pr61144.patch21
-rw-r--r--toolchain/gcc/patches/4.9-linaro/203-musl_powerpc.patch2
-rw-r--r--toolchain/gcc/patches/4.9-linaro/910-mbsd_multi.patch4
4 files changed, 6 insertions, 27 deletions
diff --git a/toolchain/gcc/common.mk b/toolchain/gcc/common.mk
index 4ee344fd16..925964ec23 100644
--- a/toolchain/gcc/common.mk
+++ b/toolchain/gcc/common.mk
@@ -42,11 +42,11 @@ ifeq ($(findstring linaro, $(CONFIG_GCC_VERSION)),linaro)
PKG_COMP:=xz
endif
ifeq ($(CONFIG_GCC_VERSION),"4.9-linaro")
- LINARO_RELEASE:=14.09
- PKG_REV:=4.9-2014.09
+ LINARO_RELEASE:=14.10
+ PKG_REV:=4.9-2014.10
PKG_VERSION:=4.9.2
PKG_VERSION_MAJOR:=4.9
- PKG_MD5SUM:=ac920b5800623ff99137d3cf23ad09ca
+ PKG_MD5SUM:=230da25b1e7661a8659eb770c5c88442
PKG_COMP:=xz
endif
ifneq ($(LINARO_RELEASE),)
diff --git a/toolchain/gcc/patches/4.9-linaro/020-fix_pr61144.patch b/toolchain/gcc/patches/4.9-linaro/020-fix_pr61144.patch
deleted file mode 100644
index a6b320d881..0000000000
--- a/toolchain/gcc/patches/4.9-linaro/020-fix_pr61144.patch
+++ /dev/null
@@ -1,21 +0,0 @@
---- a/gcc/varpool.c
-+++ b/gcc/varpool.c
-@@ -329,8 +329,16 @@ ctor_for_folding (tree decl)
-
- /* Variables declared 'const' without an initializer
- have zero as the initializer if they may not be
-- overridden at link or run time. */
-- if (!DECL_INITIAL (real_decl)
-+ overridden at link or run time.
-+
-+ It is actually requirement for C++ compiler to optimize const variables
-+ consistently. As a GNU extension, do not enfore this rule for user defined
-+ weak variables, so we support interposition on:
-+ static const int dummy = 0;
-+ extern const int foo __attribute__((__weak__, __alias__("dummy")));
-+ */
-+ if ((!DECL_INITIAL (real_decl)
-+ || (DECL_WEAK (decl) && !DECL_COMDAT (decl)))
- && (DECL_EXTERNAL (decl) || decl_replaceable_p (decl)))
- return error_mark_node;
-
diff --git a/toolchain/gcc/patches/4.9-linaro/203-musl_powerpc.patch b/toolchain/gcc/patches/4.9-linaro/203-musl_powerpc.patch
index d8150f21a6..93087bbe19 100644
--- a/toolchain/gcc/patches/4.9-linaro/203-musl_powerpc.patch
+++ b/toolchain/gcc/patches/4.9-linaro/203-musl_powerpc.patch
@@ -1,6 +1,6 @@
--- a/gcc/config.gcc
+++ b/gcc/config.gcc
-@@ -2328,6 +2328,10 @@ powerpc*-*-linux*)
+@@ -2334,6 +2334,10 @@ powerpc*-*-linux*)
powerpc*-*-linux*paired*)
tm_file="${tm_file} rs6000/750cl.h" ;;
esac
diff --git a/toolchain/gcc/patches/4.9-linaro/910-mbsd_multi.patch b/toolchain/gcc/patches/4.9-linaro/910-mbsd_multi.patch
index b150a430fc..f14f08587a 100644
--- a/toolchain/gcc/patches/4.9-linaro/910-mbsd_multi.patch
+++ b/toolchain/gcc/patches/4.9-linaro/910-mbsd_multi.patch
@@ -188,7 +188,7 @@
-Wfatal-errors -Wfloat-equal -Wformat -Wformat=2 @gol
-Wno-format-contains-nul -Wno-format-extra-args -Wformat-nonliteral @gol
-Wformat-security -Wformat-y2k @gol
-@@ -5041,6 +5041,22 @@ This option is only supported for C and
+@@ -5042,6 +5042,22 @@ This option is only supported for C and
@option{-Wall} and by @option{-Wpedantic}, which can be disabled with
@option{-Wno-pointer-sign}.
@@ -211,7 +211,7 @@
@item -Wstack-protector
@opindex Wstack-protector
@opindex Wno-stack-protector
-@@ -7188,7 +7204,7 @@ so, the first branch is redirected to ei
+@@ -7189,7 +7205,7 @@ so, the first branch is redirected to ei
second branch or a point immediately following it, depending on whether
the condition is known to be true or false.