summaryrefslogtreecommitdiffstats
path: root/toolchain/gcc
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2010-12-20 14:25:05 +0000
committerFelix Fietkau <nbd@openwrt.org>2010-12-20 14:25:05 +0000
commit014d3b98b96872d020ffccf0358ba60967b3f1c0 (patch)
treebcc4a331adfa98faa64b5e97b86b1e3d480e11e3 /toolchain/gcc
parentd2d990e41e2d6a5b367fdc18d0ff1c7e987ed208 (diff)
downloadmaster-31e0f0ae-014d3b98b96872d020ffccf0358ba60967b3f1c0.tar.gz
master-31e0f0ae-014d3b98b96872d020ffccf0358ba60967b3f1c0.tar.bz2
master-31e0f0ae-014d3b98b96872d020ffccf0358ba60967b3f1c0.zip
gcc: fix newer libstdc++ compile issues with uclibc 0.9.32
SVN-Revision: 24734
Diffstat (limited to 'toolchain/gcc')
-rw-r--r--toolchain/gcc/common.mk3
1 files changed, 3 insertions, 0 deletions
diff --git a/toolchain/gcc/common.mk b/toolchain/gcc/common.mk
index ebc5c1e6db..3a4a94a46a 100644
--- a/toolchain/gcc/common.mk
+++ b/toolchain/gcc/common.mk
@@ -95,6 +95,9 @@ SEP:=,
TARGET_LANGUAGES:="c$(if $(CONFIG_INSTALL_LIBSTDCPP),$(SEP)c++)$(if $(CONFIG_INSTALL_LIBGCJ),$(SEP)java)"
export libgcc_cv_fixed_point=no
+ifdef CONFIG_USE_UCLIBC
+ export glibcxx_cv_c99_math_tr1=no
+endif
GCC_CONFIGURE:= \
SHELL="$(BASH)" \