summaryrefslogtreecommitdiffstats
path: root/toolchain/gcc/patches/6.2.0/940-no-clobber-stamp-bits.patch
diff options
context:
space:
mode:
authorSyrone Wong <wong.syrone@gmail.com>2016-09-03 18:31:14 +0800
committerFelix Fietkau <nbd@nbd.name>2016-09-04 13:36:09 +0200
commitf8c7e935ef8060b8ab2f5ca52832ef8dfea361bc (patch)
tree7f0a398d55e7d4b181a392bffae21e0a46210c78 /toolchain/gcc/patches/6.2.0/940-no-clobber-stamp-bits.patch
parentaa53f78038d541052de8764323f6f26578327606 (diff)
downloadmaster-31e0f0ae-f8c7e935ef8060b8ab2f5ca52832ef8dfea361bc.tar.gz
master-31e0f0ae-f8c7e935ef8060b8ab2f5ca52832ef8dfea361bc.tar.bz2
master-31e0f0ae-f8c7e935ef8060b8ab2f5ca52832ef8dfea361bc.zip
toolchain/gcc: bump GCC 6.1.0 to 6.2.0
Compile and run tested on ar71xx and mvebu Signed-off-by: Syrone Wong <wong.syrone@gmail.com>
Diffstat (limited to 'toolchain/gcc/patches/6.2.0/940-no-clobber-stamp-bits.patch')
-rw-r--r--toolchain/gcc/patches/6.2.0/940-no-clobber-stamp-bits.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/toolchain/gcc/patches/6.2.0/940-no-clobber-stamp-bits.patch b/toolchain/gcc/patches/6.2.0/940-no-clobber-stamp-bits.patch
new file mode 100644
index 0000000000..65f59fcfa7
--- /dev/null
+++ b/toolchain/gcc/patches/6.2.0/940-no-clobber-stamp-bits.patch
@@ -0,0 +1,11 @@
+--- a/libstdc++-v3/include/Makefile.in
++++ b/libstdc++-v3/include/Makefile.in
+@@ -1458,7 +1458,7 @@ stamp-bits: ${bits_headers}
+ @$(STAMP) stamp-bits
+
+ stamp-bits-sup: stamp-bits ${bits_sup_headers}
+- @-cd ${bits_builddir} && $(LN_S) $? . 2>/dev/null
++ @-cd ${bits_builddir} && $(LN_S) $(filter-out stamp-bits,$?) . 2>/dev/null
+ @$(STAMP) stamp-bits-sup
+
+ stamp-c_base: ${c_base_headers}