summaryrefslogtreecommitdiffstats
path: root/toolchain/gcc/patches/6.1.0/820-libgcc_pic.patch
diff options
context:
space:
mode:
authorSyrone Wong <wong.syrone@gmail.com>2016-07-13 21:57:05 +0800
committerFelix Fietkau <nbd@nbd.name>2016-07-15 14:17:58 +0200
commit445604a915e8ed4669b3ef3c622259c7ca0081c1 (patch)
tree43d7878a49fc1b6579081828f0b94d2affd6ffe4 /toolchain/gcc/patches/6.1.0/820-libgcc_pic.patch
parenta4e90e2cac9d0afb41842b8a197b3acee903b9ad (diff)
downloadmaster-31e0f0ae-445604a915e8ed4669b3ef3c622259c7ca0081c1.tar.gz
master-31e0f0ae-445604a915e8ed4669b3ef3c622259c7ca0081c1.tar.bz2
master-31e0f0ae-445604a915e8ed4669b3ef3c622259c7ca0081c1.zip
toolchain/gcc: add 6.1.0
-fno-plt and musl-libc patches already get upstream, then dropped in GCC 6. Other patches are almost identical compared to GCC 5.4. Compile and run tested on ar71xx/Qihoo C301 and mvebu/Linksys WRT1900ac v1 Signed-off-by: Syrone Wong <wong.syrone@gmail.com> Signed-off-by: Felix Fietkau <nbd@nbd.name> [cleanups/fixes]
Diffstat (limited to 'toolchain/gcc/patches/6.1.0/820-libgcc_pic.patch')
-rw-r--r--toolchain/gcc/patches/6.1.0/820-libgcc_pic.patch36
1 files changed, 36 insertions, 0 deletions
diff --git a/toolchain/gcc/patches/6.1.0/820-libgcc_pic.patch b/toolchain/gcc/patches/6.1.0/820-libgcc_pic.patch
new file mode 100644
index 0000000000..f925d96f66
--- /dev/null
+++ b/toolchain/gcc/patches/6.1.0/820-libgcc_pic.patch
@@ -0,0 +1,36 @@
+--- a/libgcc/Makefile.in
++++ b/libgcc/Makefile.in
+@@ -888,11 +888,12 @@ $(libgcov-driver-objects): %$(objext): $
+
+ # Static libraries.
+ libgcc.a: $(libgcc-objects)
++libgcc_pic.a: $(libgcc-s-objects)
+ libgcov.a: $(libgcov-objects)
+ libunwind.a: $(libunwind-objects)
+ libgcc_eh.a: $(libgcc-eh-objects)
+
+-libgcc.a libgcov.a libunwind.a libgcc_eh.a:
++libgcc.a libgcov.a libunwind.a libgcc_eh.a libgcc_pic.a:
+ -rm -f $@
+
+ objects="$(objects)"; \
+@@ -913,7 +914,7 @@ all: libunwind.a
+ endif
+
+ ifeq ($(enable_shared),yes)
+-all: libgcc_eh.a libgcc_s$(SHLIB_EXT)
++all: libgcc_eh.a libgcc_pic.a libgcc_s$(SHLIB_EXT)
+ ifneq ($(LIBUNWIND),)
+ all: libunwind$(SHLIB_EXT)
+ libgcc_s$(SHLIB_EXT): libunwind$(SHLIB_EXT)
+@@ -1115,6 +1116,10 @@ install-shared:
+ chmod 644 $(DESTDIR)$(inst_libdir)/libgcc_eh.a
+ $(RANLIB) $(DESTDIR)$(inst_libdir)/libgcc_eh.a
+
++ $(INSTALL_DATA) libgcc_pic.a $(mapfile) $(DESTDIR)$(inst_libdir)/
++ chmod 644 $(DESTDIR)$(inst_libdir)/libgcc_pic.a
++ $(RANLIB) $(DESTDIR)$(inst_libdir)/libgcc_pic.a
++
+ $(subst @multilib_dir@,$(MULTIDIR),$(subst \
+ @shlib_base_name@,libgcc_s,$(subst \
+ @shlib_slibdir_qual@,$(MULTIOSSUBDIR),$(SHLIB_INSTALL))))