summaryrefslogtreecommitdiffstats
path: root/toolchain/gcc/common.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-11-10 12:03:59 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-11-10 12:03:59 +0000
commit8b5d644bb36846660e1fa20d38361fec12a14b28 (patch)
tree3862ad9cadac2989690765d921a16b875147180a /toolchain/gcc/common.mk
parent759b1c11872d5df4bd198aaff2a5cf7e68a85314 (diff)
downloadmaster-31e0f0ae-8b5d644bb36846660e1fa20d38361fec12a14b28.tar.gz
master-31e0f0ae-8b5d644bb36846660e1fa20d38361fec12a14b28.tar.bz2
master-31e0f0ae-8b5d644bb36846660e1fa20d38361fec12a14b28.zip
toolchain: add support of ARC architecture
This includes binutils, gcc, gdb and uClibc-ng. Latest release of ARC gcc (as of today it is "arc-2015.06") is based on upstream gcc 4.8.4. Sources are available on GitHub, see: https://github.com/foss-for-synopsys-dwc-arc-processors/gcc Latest release of ARC binutils (as of today it is "arc-2015.06") is based on upstream binutils 2.23. Sources are available on GitHub, see: https://github.com/foss-for-synopsys-dwc-arc-processors/binutils-gdb/releases/tag/arc-2015.06 Latest release of ARC GDB (as of today this is "arc-2015.06-gdb") is based on upstream gdb 7.9.1. Sources are available on GitHub, see: https://github.com/foss-for-synopsys-dwc-arc-processors/binutils-gdb/releases/tag/arc-2015.06-gdb Note that for binutils and gdb that come from unified git repository (which is the case for upstream binutils/gdb today) we need to disable building of gdb in binutils and binutils in gdb hence in binutils: ------>8------ --disable-sim --disable-gdb ------>8------ and in gdb: ------>8------ --disable-binutils --disable-ld --disable-gas ------>8------ Also in gdb we disable sim because if the following breakage while building with it: ------------>8------------ /usr/bin/env bash ./../common/genmloop.sh -shell /usr/bin/env bash \ -mono -fast -pbb -switch sem5-switch.c \ -cpu a5f -infile ./mloop5.in \ -outfile-suffix 5 unknown option: bash Makefile:699: recipe for target 'stamp-5mloop' failed make[7]: *** [stamp-5mloop] Error 1 ------------>8------------ Cc: Felix Fietkau <nbd@openwrt.org> Cc: John Crispin <blogic@openwrt.org> Cc: Jonas Gorski <jogo@openwrt.org> Signed-off-by: Alexey Brodkin <abrodkin@synopsys.com> SVN-Revision: 47438
Diffstat (limited to 'toolchain/gcc/common.mk')
-rw-r--r--toolchain/gcc/common.mk31
1 files changed, 22 insertions, 9 deletions
diff --git a/toolchain/gcc/common.mk b/toolchain/gcc/common.mk
index b33769ce50..5214765d6b 100644
--- a/toolchain/gcc/common.mk
+++ b/toolchain/gcc/common.mk
@@ -25,6 +25,19 @@ GCC_VERSION:=$(call qstrip,$(CONFIG_GCC_VERSION))
PKG_VERSION:=$(firstword $(subst +, ,$(GCC_VERSION)))
GCC_DIR:=$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE_URL:=@GNU/gcc/gcc-$(PKG_VERSION)
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+
+ifeq ($(PKG_VERSION),4.6.3)
+ PKG_MD5SUM:=773092fe5194353b02bb0110052a972e
+endif
+ifeq ($(PKG_VERSION),4.8.0)
+ PKG_MD5SUM:=e6040024eb9e761c3bea348d1fa5abb0
+endif
+ifeq ($(PKG_VERSION),5.2.0)
+ PKG_MD5SUM:=a51bcfeb3da7dd4c623e27207ed43467
+endif
+
ifeq ($(findstring linaro, $(CONFIG_GCC_VERSION)),linaro)
LINARO_RELEASE:=
ifeq ($(CONFIG_GCC_VERSION),"4.6-linaro")
@@ -49,16 +62,16 @@ ifeq ($(findstring linaro, $(CONFIG_GCC_VERSION)),linaro)
PKG_SOURCE:=$(PKG_NAME)-linaro-$(PKG_REV).tar.$(PKG_COMP)
GCC_DIR:=gcc-linaro-$(PKG_REV)
HOST_BUILD_DIR:=$(BUILD_DIR_TOOLCHAIN)/$(GCC_DIR)
-else
- PKG_SOURCE_URL:=@GNU/gcc/gcc-$(PKG_VERSION)
- PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+endif
- ifeq ($(PKG_VERSION),4.8.0)
- PKG_MD5SUM:=e6040024eb9e761c3bea348d1fa5abb0
- endif
- ifeq ($(PKG_VERSION),5.2.0)
- PKG_MD5SUM:=a51bcfeb3da7dd4c623e27207ed43467
- endif
+ifneq ($(CONFIG_GCC_VERSION_4_8_ARC),)
+ PKG_VERSION:=4.8.4
+ PKG_SOURCE_URL:=https://github.com/foss-for-synopsys-dwc-arc-processors/gcc/archive/arc-2015.06
+ PKG_SOURCE:=$(PKG_NAME)-$(GCC_VERSION).tar.gz
+ PKG_MD5SUM:=25007ebb02a5f6c32532b103bb5984a0
+ PKG_REV:=2015.06
+ GCC_DIR:=gcc-arc-$(PKG_REV)
+ HOST_BUILD_DIR = $(BUILD_DIR_HOST)/$(PKG_NAME)-$(GCC_VERSION)
endif
PATCH_DIR=../patches/$(GCC_VERSION)