summaryrefslogtreecommitdiffstats
path: root/toolchain/gcc/common.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2016-01-20 13:54:22 +0000
committerFelix Fietkau <nbd@openwrt.org>2016-01-20 13:54:22 +0000
commit6ae4479190a2d73cad047eab6e86d4a71323329b (patch)
tree40df6769e9f06c5c5709fd0bb8c6833ed3a1f0d8 /toolchain/gcc/common.mk
parent15aa6d1a164a54a75aaae3656f47e3c692c36c79 (diff)
downloadmaster-31e0f0ae-6ae4479190a2d73cad047eab6e86d4a71323329b.tar.gz
master-31e0f0ae-6ae4479190a2d73cad047eab6e86d4a71323329b.tar.bz2
master-31e0f0ae-6ae4479190a2d73cad047eab6e86d4a71323329b.zip
gcc: drop version 4.8-linaro
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 48395
Diffstat (limited to 'toolchain/gcc/common.mk')
-rw-r--r--toolchain/gcc/common.mk22
1 files changed, 0 insertions, 22 deletions
diff --git a/toolchain/gcc/common.mk b/toolchain/gcc/common.mk
index 648cd2d5ad..2912f8f612 100644
--- a/toolchain/gcc/common.mk
+++ b/toolchain/gcc/common.mk
@@ -28,32 +28,10 @@ GCC_DIR:=$(PKG_NAME)-$(PKG_VERSION)
PKG_SOURCE_URL:=@GNU/gcc/gcc-$(PKG_VERSION)
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-ifeq ($(PKG_VERSION),4.8.0)
- PKG_MD5SUM:=e6040024eb9e761c3bea348d1fa5abb0
-endif
ifeq ($(PKG_VERSION),5.2.0)
PKG_MD5SUM:=a51bcfeb3da7dd4c623e27207ed43467
endif
-ifeq ($(findstring linaro, $(CONFIG_GCC_VERSION)),linaro)
- LINARO_RELEASE:=
- ifeq ($(CONFIG_GCC_VERSION),"4.8-linaro")
- PKG_REV:=4.8-2014.04
- PKG_VERSION:=4.8.3
- PKG_VERSION_MAJOR:=4.8
- PKG_MD5SUM:=5ba2f3a449b1658ccc09d27cc7ab3c03
- PKG_COMP:=xz
- endif
- ifneq ($(LINARO_RELEASE),)
- PKG_SOURCE_URL:=http://releases.linaro.org/$(LINARO_RELEASE)/components/toolchain/gcc-linaro/$(PKG_VERSION_MAJOR)
- else
- PKG_SOURCE_URL:=http://launchpad.net/gcc-linaro/$(PKG_VERSION_MAJOR)/$(PKG_REV)/+download/
- endif
- PKG_SOURCE:=$(PKG_NAME)-linaro-$(PKG_REV).tar.$(PKG_COMP)
- GCC_DIR:=gcc-linaro-$(PKG_REV)
- HOST_BUILD_DIR:=$(BUILD_DIR_TOOLCHAIN)/$(GCC_DIR)
-endif
-
ifneq ($(CONFIG_GCC_VERSION_4_8_ARC),)
PKG_VERSION:=4.8.4
PKG_SOURCE_URL:=https://github.com/foss-for-synopsys-dwc-arc-processors/gcc/archive/arc-2015.06