summaryrefslogtreecommitdiffstats
path: root/toolchain/gcc/common.mk
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2012-11-19 23:12:00 +0000
committerFlorian Fainelli <florian@openwrt.org>2012-11-19 23:12:00 +0000
commit5d37a99a017d9f7bc819e6255ee319a29cda59a3 (patch)
tree07721792c84da272cda1c8fe84c18471ef0c76b9 /toolchain/gcc/common.mk
parentcf440ae7169f9095ea2089269d894a8a60de3161 (diff)
downloadmaster-31e0f0ae-5d37a99a017d9f7bc819e6255ee319a29cda59a3.tar.gz
master-31e0f0ae-5d37a99a017d9f7bc819e6255ee319a29cda59a3.tar.bz2
master-31e0f0ae-5d37a99a017d9f7bc819e6255ee319a29cda59a3.zip
gcc: build with HOST_CFLAGS
Turns on -O2 optimization when building GCC thus making the cross-compiler a little faster (about 25%). Signed-off-by: Florian Fainelli <florian@openwrt.org> SVN-Revision: 34266
Diffstat (limited to 'toolchain/gcc/common.mk')
-rw-r--r--toolchain/gcc/common.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/toolchain/gcc/common.mk b/toolchain/gcc/common.mk
index 6e4c61214b..924ed90a63 100644
--- a/toolchain/gcc/common.mk
+++ b/toolchain/gcc/common.mk
@@ -180,6 +180,7 @@ endif
GCC_MAKE:= \
export SHELL="$(BASH)"; \
$(MAKE) \
+ CFLAGS="$(HOST_CFLAGS)" \
CFLAGS_FOR_TARGET="$(TARGET_CFLAGS)" \
CXXFLAGS_FOR_TARGET="$(TARGET_CFLAGS)"