summaryrefslogtreecommitdiffstats
path: root/toolchain/binutils
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2014-12-27 13:00:09 +0000
committerFelix Fietkau <nbd@openwrt.org>2014-12-27 13:00:09 +0000
commitf38436f607555351bcefcd7cc6497b000ee79381 (patch)
treef050af685bef864208d1d6505bd2872af0867aec /toolchain/binutils
parent9a467998042abfc0b1c7c5e4420c27615544cee3 (diff)
downloadmaster-31e0f0ae-f38436f607555351bcefcd7cc6497b000ee79381.tar.gz
master-31e0f0ae-f38436f607555351bcefcd7cc6497b000ee79381.tar.bz2
master-31e0f0ae-f38436f607555351bcefcd7cc6497b000ee79381.zip
binutils: run install twice instead of overwriting the final toolchain with the initial one
fixes compiler error after a binutils rebuild/reinstall without rebuilding the rest of the toolchain Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 43785
Diffstat (limited to 'toolchain/binutils')
-rw-r--r--toolchain/binutils/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/toolchain/binutils/Makefile b/toolchain/binutils/Makefile
index 8e661b98eb..8441f740ac 100644
--- a/toolchain/binutils/Makefile
+++ b/toolchain/binutils/Makefile
@@ -84,9 +84,11 @@ define Host/Install
$(MAKE) -C $(HOST_BUILD_DIR) \
prefix=$(TOOLCHAIN_DIR)/initial \
install
+ $(MAKE) -C $(HOST_BUILD_DIR) \
+ prefix=$(TOOLCHAIN_DIR) \
+ install
$(call FixupLibdir,$(TOOLCHAIN_DIR)/initial)
$(RM) $(TOOLCHAIN_DIR)/initial/lib/libiberty.a
- $(CP) $(TOOLCHAIN_DIR)/initial/. $(TOOLCHAIN_DIR)/
$(CP) $(TOOLCHAIN_DIR)/bin/$(REAL_GNU_TARGET_NAME)-readelf $(REAL_STAGING_DIR_HOST)/bin/readelf
endef