summaryrefslogtreecommitdiffstats
path: root/toolchain/binutils
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2014-10-18 19:25:24 +0000
committerFelix Fietkau <nbd@openwrt.org>2014-10-18 19:25:24 +0000
commitb537205ea2892cd23da6f75730dae04da8aad128 (patch)
tree0e3258f934c3e0a146812e294ef4d29fe8e583aa /toolchain/binutils
parente641bb026b814a3743571956fc8af68b39afd66b (diff)
downloadmaster-31e0f0ae-b537205ea2892cd23da6f75730dae04da8aad128.tar.gz
master-31e0f0ae-b537205ea2892cd23da6f75730dae04da8aad128.tar.bz2
master-31e0f0ae-b537205ea2892cd23da6f75730dae04da8aad128.zip
toolchain: fix binutils broken symlink
The Makefile for binutils creates a broken symlink to "binutils-linaro" in "trunk/build_dir/toolchain-<target>_gcc-4.9-linaro_uClibc-0.9.33.2". Modify the Makefile to point the symlink to the correct directory. Signed-off-by: Nathan Hintz <nlhintz@hotmail.com> SVN-Revision: 42954
Diffstat (limited to 'toolchain/binutils')
-rw-r--r--toolchain/binutils/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/toolchain/binutils/Makefile b/toolchain/binutils/Makefile
index 567f88a854..b88fbd8b2c 100644
--- a/toolchain/binutils/Makefile
+++ b/toolchain/binutils/Makefile
@@ -63,7 +63,7 @@ endif
define Host/Prepare
$(call Host/Prepare/Default)
- ln -snf $(PKG_NAME)-$(PKG_VERSION) $(BUILD_DIR_TOOLCHAIN)/$(PKG_NAME)
+ ln -snf $(notdir $(HOST_BUILD_DIR)) $(BUILD_DIR_TOOLCHAIN)/$(PKG_NAME)
$(CP) $(SCRIPT_DIR)/config.{guess,sub} $(HOST_BUILD_DIR)/
endef