summaryrefslogtreecommitdiffstats
path: root/toolchain/binutils
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2014-12-27 12:59:53 +0000
committerFelix Fietkau <nbd@openwrt.org>2014-12-27 12:59:53 +0000
commit7d808a325d47f1f5ae09db0eb8a99e6cfe5632c9 (patch)
tree0e542b27085b38ca07c2ec7739a35d36d92c3629 /toolchain/binutils
parentb2de18bea4830a193e1bf5863a0e11e47158c15d (diff)
downloadmaster-31e0f0ae-7d808a325d47f1f5ae09db0eb8a99e6cfe5632c9.tar.gz
master-31e0f0ae-7d808a325d47f1f5ae09db0eb8a99e6cfe5632c9.tar.bz2
master-31e0f0ae-7d808a325d47f1f5ae09db0eb8a99e6cfe5632c9.zip
binutils: enable plugin support
--enable-plugin is necessary for gcc-ar, gcc-nm and gcc-ranlib to work, which must be used with GCC 4.9 for LTO to work. Without this option, gcc-ar etc. will just fail with sorry - this program has been built without plugin support Using the normal ar from binutils with GCC 4.9 and -flto will cause linking with static "convenience" libraries to fail. Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net> SVN-Revision: 43783
Diffstat (limited to 'toolchain/binutils')
-rw-r--r--toolchain/binutils/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/toolchain/binutils/Makefile b/toolchain/binutils/Makefile
index 820b5f8efa..8e661b98eb 100644
--- a/toolchain/binutils/Makefile
+++ b/toolchain/binutils/Makefile
@@ -41,6 +41,7 @@ BINUTILS_CONFIGURE:= \
--host=$(GNU_HOST_NAME) \
--target=$(REAL_GNU_TARGET_NAME) \
--with-sysroot=$(TOOLCHAIN_DIR) \
+ --enable-plugins \
--disable-multilib \
--disable-werror \
--disable-nls \