summaryrefslogtreecommitdiffstats
path: root/toolchain/binutils
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-01-26 04:54:25 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-01-26 04:54:25 +0000
commit19f8937c77871bf79469c16abe61584a8c5c9ed8 (patch)
tree047432fdaa711d881303d46930214a20924ecfae /toolchain/binutils
parent10e3ea9f129ce908abf7e1e73e318aef7d2f5e16 (diff)
downloadmaster-31e0f0ae-19f8937c77871bf79469c16abe61584a8c5c9ed8.tar.gz
master-31e0f0ae-19f8937c77871bf79469c16abe61584a8c5c9ed8.tar.bz2
master-31e0f0ae-19f8937c77871bf79469c16abe61584a8c5c9ed8.zip
install readelf to STAGING_DIR_HOST (eglibc requires it, not all systems have it)
SVN-Revision: 14196
Diffstat (limited to 'toolchain/binutils')
-rw-r--r--toolchain/binutils/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/toolchain/binutils/Makefile b/toolchain/binutils/Makefile
index e6f60a846c..93d6392201 100644
--- a/toolchain/binutils/Makefile
+++ b/toolchain/binutils/Makefile
@@ -24,6 +24,7 @@ endif
PATCH_DIR:=./patches/$(PKG_VERSION)
+REAL_STAGING_DIR_HOST:=$(STAGING_DIR_HOST)
STAGING_DIR_HOST:=$(TOOLCHAIN_DIR)
BUILD_DIR_HOST:=$(BUILD_DIR_TOOLCHAIN)
@@ -62,6 +63,7 @@ endef
define Build/Install
$(MAKE) -C $(PKG_BUILD_DIR) install
+ $(CP) $(TOOLCHAIN_DIR)/usr/bin/$(REAL_GNU_TARGET_NAME)-readelf $(REAL_STAGING_DIR_HOST)/bin/readelf
endef
define Build/Clean