summaryrefslogtreecommitdiffstats
path: root/toolchain/binutils/patches
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2009-02-03 16:23:01 +0000
committerNicolas Thill <nico@openwrt.org>2009-02-03 16:23:01 +0000
commit22e91f881e876b6bbb20fa26ab758ac6e338016c (patch)
tree7110af1d01645117d627b3337f9801c5ef5882a5 /toolchain/binutils/patches
parent04cb388e2a3ab319e07e6a76216b72d2b93b73de (diff)
downloadmaster-31e0f0ae-22e91f881e876b6bbb20fa26ab758ac6e338016c.tar.gz
master-31e0f0ae-22e91f881e876b6bbb20fa26ab758ac6e338016c.tar.bz2
master-31e0f0ae-22e91f881e876b6bbb20fa26ab758ac6e338016c.zip
binutils: add support for v2.19.1 (from #4492, thanks to dwrobel)
SVN-Revision: 14393
Diffstat (limited to 'toolchain/binutils/patches')
-rw-r--r--toolchain/binutils/patches/2.19.1/110-arm-eabi-conf.patch22
-rw-r--r--toolchain/binutils/patches/2.19.1/120-sh-conf.patch40
-rw-r--r--toolchain/binutils/patches/2.19.1/300-001_ld_makefile_patch.patch22
-rw-r--r--toolchain/binutils/patches/2.19.1/300-012_check_ldrunpath_length.patch20
4 files changed, 104 insertions, 0 deletions
diff --git a/toolchain/binutils/patches/2.19.1/110-arm-eabi-conf.patch b/toolchain/binutils/patches/2.19.1/110-arm-eabi-conf.patch
new file mode 100644
index 0000000000..02f663bc5a
--- /dev/null
+++ b/toolchain/binutils/patches/2.19.1/110-arm-eabi-conf.patch
@@ -0,0 +1,22 @@
+--- a/configure
++++ b/configure
+@@ -2313,7 +2313,7 @@ case "${target}" in
+ noconfigdirs="$noconfigdirs target-libffi target-qthreads"
+ libgloss_dir=arm
+ ;;
+- arm*-*-linux-gnueabi)
++ arm*-*-linux-*gnueabi)
+ noconfigdirs="$noconfigdirs target-qthreads"
+ case ${with_newlib} in
+ no) noconfigdirs="$noconfigdirs target-newlib target-libgloss"
+--- a/configure.ac
++++ b/configure.ac
+@@ -562,7 +562,7 @@ case "${target}" in
+ noconfigdirs="$noconfigdirs target-libffi target-qthreads"
+ libgloss_dir=arm
+ ;;
+- arm*-*-linux-gnueabi)
++ arm*-*-linux-*gnueabi)
+ noconfigdirs="$noconfigdirs target-qthreads"
+ case ${with_newlib} in
+ no) noconfigdirs="$noconfigdirs target-newlib target-libgloss"
diff --git a/toolchain/binutils/patches/2.19.1/120-sh-conf.patch b/toolchain/binutils/patches/2.19.1/120-sh-conf.patch
new file mode 100644
index 0000000000..0ad50ddedd
--- /dev/null
+++ b/toolchain/binutils/patches/2.19.1/120-sh-conf.patch
@@ -0,0 +1,40 @@
+--- a/configure
++++ b/configure
+@@ -2281,7 +2281,7 @@ case "${target}" in
+ am33_2.0-*-linux*)
+ noconfigdirs="$noconfigdirs ${libgcj} target-newlib target-libgloss"
+ ;;
+- sh-*-linux*)
++ sh*-*-linux*)
+ noconfigdirs="$noconfigdirs ${libgcj} target-newlib target-libgloss"
+ ;;
+ sh*-*-pe|mips*-*-pe|*arm-wince-pe)
+@@ -2606,7 +2606,7 @@ case "${target}" in
+ romp-*-*)
+ noconfigdirs="$noconfigdirs bfd binutils ld gas opcodes target-libgloss ${libgcj}"
+ ;;
+- sh-*-* | sh64-*-*)
++ sh*-*-* | sh64-*-*)
+ case "${host}" in
+ i[3456789]86-*-vsta) ;; # don't add gprof back in
+ i[3456789]86-*-go32*) ;; # don't add gprof back in
+--- a/configure.ac
++++ b/configure.ac
+@@ -530,7 +530,7 @@ case "${target}" in
+ am33_2.0-*-linux*)
+ noconfigdirs="$noconfigdirs ${libgcj} target-newlib target-libgloss"
+ ;;
+- sh-*-linux*)
++ sh*-*-linux*)
+ noconfigdirs="$noconfigdirs ${libgcj} target-newlib target-libgloss"
+ ;;
+ sh*-*-pe|mips*-*-pe|*arm-wince-pe)
+@@ -855,7 +855,7 @@ case "${target}" in
+ romp-*-*)
+ noconfigdirs="$noconfigdirs bfd binutils ld gas opcodes target-libgloss ${libgcj}"
+ ;;
+- sh-*-* | sh64-*-*)
++ sh*-*-* | sh64-*-*)
+ case "${host}" in
+ i[[3456789]]86-*-vsta) ;; # don't add gprof back in
+ i[[3456789]]86-*-go32*) ;; # don't add gprof back in
diff --git a/toolchain/binutils/patches/2.19.1/300-001_ld_makefile_patch.patch b/toolchain/binutils/patches/2.19.1/300-001_ld_makefile_patch.patch
new file mode 100644
index 0000000000..74e9f58219
--- /dev/null
+++ b/toolchain/binutils/patches/2.19.1/300-001_ld_makefile_patch.patch
@@ -0,0 +1,22 @@
+--- a/ld/Makefile.am
++++ b/ld/Makefile.am
+@@ -18,7 +18,7 @@ AM_CFLAGS = $(WARN_CFLAGS)
+ # We put the scripts in the directory $(scriptdir)/ldscripts.
+ # We can't put the scripts in $(datadir) because the SEARCH_DIR
+ # directives need to be different for native and cross linkers.
+-scriptdir = $(tooldir)/lib
++scriptdir = $(libdir)
+
+ EMUL = @EMUL@
+ EMULATION_OFILES = @EMULATION_OFILES@
+--- a/ld/Makefile.in
++++ b/ld/Makefile.in
+@@ -291,7 +291,7 @@ AM_CFLAGS = $(WARN_CFLAGS)
+ # We put the scripts in the directory $(scriptdir)/ldscripts.
+ # We can't put the scripts in $(datadir) because the SEARCH_DIR
+ # directives need to be different for native and cross linkers.
+-scriptdir = $(tooldir)/lib
++scriptdir = $(libdir)
+ BASEDIR = $(srcdir)/..
+ BFDDIR = $(BASEDIR)/bfd
+ INCDIR = $(BASEDIR)/include
diff --git a/toolchain/binutils/patches/2.19.1/300-012_check_ldrunpath_length.patch b/toolchain/binutils/patches/2.19.1/300-012_check_ldrunpath_length.patch
new file mode 100644
index 0000000000..bcafe572fb
--- /dev/null
+++ b/toolchain/binutils/patches/2.19.1/300-012_check_ldrunpath_length.patch
@@ -0,0 +1,20 @@
+--- a/ld/emultempl/elf32.em
++++ b/ld/emultempl/elf32.em
+@@ -1219,6 +1219,8 @@ fragment <<EOF
+ && command_line.rpath == NULL)
+ {
+ lib_path = (const char *) getenv ("LD_RUN_PATH");
++ if ((lib_path) && (strlen (lib_path) == 0))
++ lib_path = NULL;
+ if (gld${EMULATION_NAME}_search_needed (lib_path, &n,
+ force))
+ break;
+@@ -1404,6 +1406,8 @@ gld${EMULATION_NAME}_before_allocation (
+ rpath = command_line.rpath;
+ if (rpath == NULL)
+ rpath = (const char *) getenv ("LD_RUN_PATH");
++ if ((rpath) && (strlen (rpath) == 0))
++ rpath = NULL;
+ if (! (bfd_elf_size_dynamic_sections
+ (link_info.output_bfd, command_line.soname, rpath,
+ command_line.filter_shlib,