summaryrefslogtreecommitdiffstats
path: root/toolchain/binutils/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-02-22 04:37:20 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-02-22 04:37:20 +0000
commit7eb15898755be46e94078faffdacd8c9b0ce66cd (patch)
tree89dc171f7b7c646be5a38ca7d7b99e1be24fa61f /toolchain/binutils/Makefile
parent6ccc1c8e3c9ad0ac95c728573c300264943d8338 (diff)
downloadmaster-31e0f0ae-7eb15898755be46e94078faffdacd8c9b0ce66cd.tar.gz
master-31e0f0ae-7eb15898755be46e94078faffdacd8c9b0ce66cd.tar.bz2
master-31e0f0ae-7eb15898755be46e94078faffdacd8c9b0ce66cd.zip
build system refactoring in preparation for allowing packages to do host-build steps
SVN-Revision: 14610
Diffstat (limited to 'toolchain/binutils/Makefile')
-rw-r--r--toolchain/binutils/Makefile22
1 files changed, 11 insertions, 11 deletions
diff --git a/toolchain/binutils/Makefile b/toolchain/binutils/Makefile
index dba6d45688..b0b65f381b 100644
--- a/toolchain/binutils/Makefile
+++ b/toolchain/binutils/Makefile
@@ -61,30 +61,30 @@ ifneq ($(CONFIG_EXTRA_TARGET_ARCH),)
--enable-targets=$(call qstrip,$(CONFIG_EXTRA_TARGET_ARCH_NAME))-linux-$(TARGET_SUFFIX)
endif
-define Build/Prepare
- $(call Build/Prepare/Default)
+define Host/Prepare
+ $(call Host/Prepare/Default)
ln -snf $(PKG_NAME)-$(PKG_VERSION) $(BUILD_DIR_TOOLCHAIN)/$(PKG_NAME)
- $(CP) $(SCRIPT_DIR)/config.{guess,sub} $(PKG_BUILD_DIR)/
+ $(CP) $(SCRIPT_DIR)/config.{guess,sub} $(HOST_BUILD_DIR)/
endef
-define Build/Configure
- (cd $(PKG_BUILD_DIR); \
+define Host/Configure
+ (cd $(HOST_BUILD_DIR); \
$(BINUTILS_CONFIGURE) \
);
endef
-define Build/Compile
- $(MAKE) -C $(PKG_BUILD_DIR) all
+define Host/Compile
+ $(MAKE) -C $(HOST_BUILD_DIR) all
endef
-define Build/Install
- $(MAKE) -C $(PKG_BUILD_DIR) install
+define Host/Install
+ $(MAKE) -C $(HOST_BUILD_DIR) install
$(CP) $(TOOLCHAIN_DIR)/usr/bin/$(REAL_GNU_TARGET_NAME)-readelf $(REAL_STAGING_DIR_HOST)/bin/readelf
endef
-define Build/Clean
+define Host/Clean
rm -rf \
- $(PKG_BUILD_DIR) \
+ $(HOST_BUILD_DIR) \
$(BUILD_DIR_TOOLCHAIN)/$(PKG_NAME)
endef