summaryrefslogtreecommitdiffstats
path: root/toolchain/binutils/Makefile
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2009-02-03 21:25:48 +0000
committerNicolas Thill <nico@openwrt.org>2009-02-03 21:25:48 +0000
commit33a0eb3613da33aafd435eb4ed1e985944f42c78 (patch)
tree73adfaa44c084674b08e2c82942d3b3dfa330d9d /toolchain/binutils/Makefile
parent1716050f0c274d198abebf2b9e21fb9f754c199a (diff)
downloadmaster-31e0f0ae-33a0eb3613da33aafd435eb4ed1e985944f42c78.tar.gz
master-31e0f0ae-33a0eb3613da33aafd435eb4ed1e985944f42c78.tar.bz2
master-31e0f0ae-33a0eb3613da33aafd435eb4ed1e985944f42c78.zip
cosmetic & coherency fixes
SVN-Revision: 14397
Diffstat (limited to 'toolchain/binutils/Makefile')
-rw-r--r--toolchain/binutils/Makefile38
1 files changed, 22 insertions, 16 deletions
diff --git a/toolchain/binutils/Makefile b/toolchain/binutils/Makefile
index 925478c414..dba6d45688 100644
--- a/toolchain/binutils/Makefile
+++ b/toolchain/binutils/Makefile
@@ -35,12 +35,30 @@ override CONFIG_AUTOREBUILD=
include $(INCLUDE_DIR)/host-build.mk
-EXTRA_TARGET=$(if $(CONFIG_EXTRA_TARGET_ARCH),--enable-targets=$(call qstrip,$(CONFIG_EXTRA_TARGET_ARCH_NAME))-linux-$(TARGET_SUFFIX))
+BINUTILS_CONFIGURE:= \
+ ./configure \
+ --prefix=$(TOOLCHAIN_DIR)/usr \
+ --build=$(GNU_HOST_NAME) \
+ --host=$(GNU_HOST_NAME) \
+ --target=$(REAL_GNU_TARGET_NAME) \
+ --with-sysroot=$(TOOLCHAIN_DIR) \
+ --disable-multilib \
+ --disable-werror \
+ --disable-nls \
+ $(SOFT_FLOAT_CONFIG_OPTION) \
+ $(call qstrip,$(CONFIG_EXTRA_BINUTILS_CONFIG_OPTIONS)) \
ifneq ($(CONFIG_SSP_SUPPORT),)
- LIB_SSP:=--enable-libssp
+ BINUTILS_CONFIGURE+= \
+ --enable-libssp
else
- LIB_SSP:=--disable-libssp
+ BINUTILS_CONFIGURE+= \
+ --disable-libssp
+endif
+
+ifneq ($(CONFIG_EXTRA_TARGET_ARCH),)
+ BINUTILS_CONFIGURE+= \
+ --enable-targets=$(call qstrip,$(CONFIG_EXTRA_TARGET_ARCH_NAME))-linux-$(TARGET_SUFFIX)
endif
define Build/Prepare
@@ -51,19 +69,7 @@ endef
define Build/Configure
(cd $(PKG_BUILD_DIR); \
- ./configure \
- --prefix=$(TOOLCHAIN_DIR)/usr \
- --build=$(GNU_HOST_NAME) \
- --host=$(GNU_HOST_NAME) \
- --target=$(REAL_GNU_TARGET_NAME) \
- --with-sysroot=$(TOOLCHAIN_DIR) \
- --disable-multilib \
- --disable-werror \
- --disable-nls \
- $(LIB_SSP) \
- $(EXTRA_TARGET) \
- $(SOFT_FLOAT_CONFIG_OPTION) \
- $(call qstrip,$(CONFIG_EXTRA_BINUTILS_CONFIG_OPTIONS)) \
+ $(BINUTILS_CONFIGURE) \
);
endef