summaryrefslogtreecommitdiffstats
path: root/toolchain/binutils/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-10-19 02:09:59 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-10-19 02:09:59 +0000
commit0b077fa3a720c53504d5cda7e0e48001aca36ac8 (patch)
tree2d88e65ca049b9566c2c582c88a10617e59a0a45 /toolchain/binutils/Makefile
parentf0f100551d198386be26e29201297f4c29e7d7fd (diff)
downloadmaster-31e0f0ae-0b077fa3a720c53504d5cda7e0e48001aca36ac8.tar.gz
master-31e0f0ae-0b077fa3a720c53504d5cda7e0e48001aca36ac8.tar.bz2
master-31e0f0ae-0b077fa3a720c53504d5cda7e0e48001aca36ac8.zip
add a binutils variant based on a binutils snapshot and codesourcery g++ enhancements (compiles, but fails to link the kernel)
SVN-Revision: 18060
Diffstat (limited to 'toolchain/binutils/Makefile')
-rw-r--r--toolchain/binutils/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/toolchain/binutils/Makefile b/toolchain/binutils/Makefile
index c9da2cfd78..7073507dee 100644
--- a/toolchain/binutils/Makefile
+++ b/toolchain/binutils/Makefile
@@ -8,6 +8,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=binutils
PKG_VERSION:=$(call qstrip,$(CONFIG_BINUTILS_VERSION))
+BIN_VERSION:=$(PKG_VERSION)
PKG_SOURCE_URL:=@GNU/binutils/
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
@@ -18,6 +19,13 @@ endif
ifeq ($(PKG_VERSION),2.19.1)
PKG_MD5SUM:=09a8c5821a2dfdbb20665bc0bd680791
endif
+ifeq ($(PKG_VERSION),2.19.1+cs)
+ BIN_VERSION:=20090205
+ PKG_SOURCE:=$(PKG_NAME)-$(BIN_VERSION).tar.bz2
+ PKG_SOURCE_URL:=http://mirror2.openwrt.org/sources
+ PKG_MD5SUM:=040740e8c864dd1a15886753f9c0bc0b
+ HOST_BUILD_DIR:=$(BUILD_DIR_TOOLCHAIN)/binutils-$(BIN_VERSION)
+endif
PATCH_DIR:=./patches/$(PKG_VERSION)