summaryrefslogtreecommitdiffstats
path: root/toolchain/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-12-14 05:10:23 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-12-14 05:10:23 +0000
commitf74dd32cbad5458580f30a86a46e9e59ffa085e0 (patch)
tree42e0c92571f97864244eb5bb6cd9184257db5b79 /toolchain/Makefile
parent40d58259b75c634fb9b784c93281c9832d6be3c4 (diff)
downloadmaster-31e0f0ae-f74dd32cbad5458580f30a86a46e9e59ffa085e0.tar.gz
master-31e0f0ae-f74dd32cbad5458580f30a86a46e9e59ffa085e0.tar.bz2
master-31e0f0ae-f74dd32cbad5458580f30a86a46e9e59ffa085e0.zip
fix ccache build order
SVN-Revision: 5783
Diffstat (limited to 'toolchain/Makefile')
-rw-r--r--toolchain/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/toolchain/Makefile b/toolchain/Makefile
index ceae2269a6..4682dbed17 100644
--- a/toolchain/Makefile
+++ b/toolchain/Makefile
@@ -25,7 +25,10 @@ install: $(TARGETS_INSTALL)
clean: $(TARGETS_CLEAN)
$(TARGETS_INSTALL): $(STAGING_DIR)/$(REAL_GNU_TARGET_NAME)
-uClibc-prepare: ccache-prepare kernel-headers-prepare
+ifeq ($(CONFIG_CCACHE),y)
+ uClibc-prepare: ccache-install
+endif
+uClibc-prepare: kernel-headers-prepare
ifeq ($(CONFIG_NATIVE_TOOLCHAIN),)
binutils-prepare: uClibc-prepare
gcc-prepare: binutils-install