summaryrefslogtreecommitdiffstats
path: root/toolchain/Makefile
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2006-12-11 16:42:57 +0000
committerFlorian Fainelli <florian@openwrt.org>2006-12-11 16:42:57 +0000
commitb492e69bd2d09aaa2c3c76b52203cbb3527eb2f7 (patch)
treee6b1285c4bb8741de5cd4b8379cc9ab4efb5d364 /toolchain/Makefile
parent0094325d66e2aa009184629f8ac934f4c16df2de (diff)
downloadmaster-31e0f0ae-b492e69bd2d09aaa2c3c76b52203cbb3527eb2f7.tar.gz
master-31e0f0ae-b492e69bd2d09aaa2c3c76b52203cbb3527eb2f7.tar.bz2
master-31e0f0ae-b492e69bd2d09aaa2c3c76b52203cbb3527eb2f7.zip
Add ccache if not installed/installable on the host-system
SVN-Revision: 5758
Diffstat (limited to 'toolchain/Makefile')
-rw-r--r--toolchain/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/toolchain/Makefile b/toolchain/Makefile
index 3f12218c29..ceae2269a6 100644
--- a/toolchain/Makefile
+++ b/toolchain/Makefile
@@ -10,6 +10,7 @@ include $(TOPDIR)/rules.mk
TARGETS-y:=kernel-headers
TARGETS-$(CONFIG_GDB) += gdb
+TARGETS-$(CONFIG_CCACHE) += ccache
ifeq ($(CONFIG_NATIVE_TOOLCHAIN),)
TARGETS-y+=binutils gcc uClibc
endif
@@ -24,7 +25,7 @@ install: $(TARGETS_INSTALL)
clean: $(TARGETS_CLEAN)
$(TARGETS_INSTALL): $(STAGING_DIR)/$(REAL_GNU_TARGET_NAME)
-uClibc-prepare: kernel-headers-prepare
+uClibc-prepare: ccache-prepare kernel-headers-prepare
ifeq ($(CONFIG_NATIVE_TOOLCHAIN),)
binutils-prepare: uClibc-prepare
gcc-prepare: binutils-install