summaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorMathias Kresin <dev@kresin.me>2016-09-04 08:56:05 +0200
committerMathias Kresin <dev@kresin.me>2016-09-04 08:56:05 +0200
commite7ec7a08aae0afb1064d1bf26a9cd6fe1e64d516 (patch)
tree46113a53b6412da941652d98c1ba560df2226456 /target
parentddd259b0d5d0d4ec0084cb7cb30992b63780e962 (diff)
downloadmaster-31e0f0ae-e7ec7a08aae0afb1064d1bf26a9cd6fe1e64d516.tar.gz
master-31e0f0ae-e7ec7a08aae0afb1064d1bf26a9cd6fe1e64d516.tar.bz2
master-31e0f0ae-e7ec7a08aae0afb1064d1bf26a9cd6fe1e64d516.zip
image: use k as unit suffix for blocksize
Use k as unit suffix for kilobyte to have a the same unit regardless of the used filesystem. Signed-off-by: Mathias Kresin <dev@kresin.me>
Diffstat (limited to 'target')
-rw-r--r--target/linux/apm821xx/image/Makefile4
-rw-r--r--target/linux/bcm53xx/image/Makefile2
-rw-r--r--target/linux/imx6/image/Makefile4
-rw-r--r--target/linux/ipq806x/image/Makefile16
-rw-r--r--target/linux/kirkwood/image/Makefile2
-rw-r--r--target/linux/lantiq/image/Makefile4
-rw-r--r--target/linux/mvebu/image/Makefile8
-rw-r--r--target/linux/oxnas/image/Makefile2
-rw-r--r--target/linux/ramips/image/mt7621.mk4
9 files changed, 23 insertions, 23 deletions
diff --git a/target/linux/apm821xx/image/Makefile b/target/linux/apm821xx/image/Makefile
index 38877f9bca..3ec8ae0cee 100644
--- a/target/linux/apm821xx/image/Makefile
+++ b/target/linux/apm821xx/image/Makefile
@@ -69,7 +69,7 @@ define Device/mr24
DEVICE_PACKAGES := kmod-spi-gpio kmod-ath9k wpad-mini
DEVICE_PROFILE := MR24
DEVICE_DTS := MR24
- BLOCKSIZE := 64512
+ BLOCKSIZE := 63k
IMAGES := sysupgrade.tar
DTB_SIZE := 64512
KERNEL_SIZE := 1984k
@@ -150,7 +150,7 @@ define Device/WNDR4700
DEVICE_DTS := wndr4700
PAGESIZE := 2048
SUBPAGESIZE := 512
- BLOCKSIZE := 131072
+ BLOCKSIZE := 128k
DTB_SIZE := 131008
IMAGE_SIZE:=25559040
IMAGES := factory.img sysupgrade.tar
diff --git a/target/linux/bcm53xx/image/Makefile b/target/linux/bcm53xx/image/Makefile
index 22507b0480..2f45a7b440 100644
--- a/target/linux/bcm53xx/image/Makefile
+++ b/target/linux/bcm53xx/image/Makefile
@@ -83,7 +83,7 @@ define Device/Default
KERNEL_NAME := zImage
IMAGE_NAME = $$(IMAGE_PREFIX)-$$(1).$$(2)
IMAGES := trx
- BLOCKSIZE := 128KiB
+ BLOCKSIZE := 128k
PAGESIZE := 2048
UBINIZE_OPTS :=
IMAGE/trx := append-ubi | trx-nand
diff --git a/target/linux/imx6/image/Makefile b/target/linux/imx6/image/Makefile
index ad89da8d82..86e3308c79 100644
--- a/target/linux/imx6/image/Makefile
+++ b/target/linux/imx6/image/Makefile
@@ -100,7 +100,7 @@ define Device/ventana
IMAGE/bootfs.tar.gz := bootfs.tar.gz | install-dtb
IMAGE_NAME = $$(IMAGE_PREFIX)-$$(1)-$$(2)
PAGESIZE := 2048
- BLOCKSIZE := 128KiB
+ BLOCKSIZE := 128k
MKUBIFS_OPTS := -m $$(PAGESIZE) -e 124KiB
endef
@@ -110,7 +110,7 @@ define Device/ventana-large
DEVICE_TITLE := Gateworks Ventana family (large NAND flash)
IMAGES := nand.ubi
PAGESIZE := 4096
- BLOCKSIZE := 256KiB
+ BLOCKSIZE := 256k
MKUBIFS_OPTS := -m $$(PAGESIZE) -e 248KiB
endef
diff --git a/target/linux/ipq806x/image/Makefile b/target/linux/ipq806x/image/Makefile
index 8c1064e552..ff5be05d0d 100644
--- a/target/linux/ipq806x/image/Makefile
+++ b/target/linux/ipq806x/image/Makefile
@@ -94,7 +94,7 @@ define Device/AP148
$(call Device/FitImage)
$(call Device/UbiFit)
DEVICE_DTS := qcom-ipq8064-ap148
- BLOCKSIZE := 128KiB
+ BLOCKSIZE := 128k
PAGESIZE := 2048
BOARD_NAME := ap148
DEVICE_TITLE := Qualcomm AP148
@@ -105,7 +105,7 @@ define Device/AP148-legacy
$(call Device/LegacyImage)
$(call Device/UbiFit)
DEVICE_DTS := qcom-ipq8064-ap148
- BLOCKSIZE := 128KiB
+ BLOCKSIZE := 128k
PAGESIZE := 2048
BOARD_NAME := ap148
DEVICE_TITLE := Qualcomm AP148 (legacy)
@@ -115,7 +115,7 @@ endef
define Device/C2600
$(call Device/TpSafeImage)
DEVICE_DTS := qcom-ipq8064-c2600
- BLOCKSIZE := 128KiB
+ BLOCKSIZE := 128k
PAGESIZE := 2048
BOARD_NAME := c2600
TPLINK_BOARD_NAME := C2600
@@ -129,7 +129,7 @@ define Device/D7800
KERNEL_SIZE := 2097152
NETGEAR_BOARD_ID := D7800
NETGEAR_HW_ID := 29764958+0+128+512+4x4+4x4
- BLOCKSIZE := 128KiB
+ BLOCKSIZE := 128k
PAGESIZE := 2048
BOARD_NAME := d7800
DEVICE_TITLE := Netgear Nighthawk X4 D7800
@@ -149,7 +149,7 @@ define Device/EA8500
$(call Device/LegacyImage)
DEVICE_DTS := qcom-ipq8064-ea8500
PAGESIZE := 2048
- BLOCKSIZE := 128KiB
+ BLOCKSIZE := 128k
KERNEL_SIZE := 3145728
FILESYSTEMS := squashfs
KERNEL = kernel-bin | append-dtb | uImage none | append-file $(KDIR)/root.dummy
@@ -168,7 +168,7 @@ define Device/R7500
KERNEL_SIZE := 2097152
NETGEAR_BOARD_ID := R7500
NETGEAR_HW_ID := 29764841+0+128+256+3x3+4x4
- BLOCKSIZE := 128KiB
+ BLOCKSIZE := 128k
PAGESIZE := 2048
BOARD_NAME := r7500
DEVICE_TITLE := Netgear Nighthawk X4 R7500
@@ -181,7 +181,7 @@ define Device/R7500v2
KERNEL_SIZE := 2097152
NETGEAR_BOARD_ID := R7500v2
NETGEAR_HW_ID := 29764958+0+128+512+3x3+4x4
- BLOCKSIZE := 128KiB
+ BLOCKSIZE := 128k
PAGESIZE := 2048
BOARD_NAME := r7500v2
DEVICE_TITLE := Netgear Nighthawk X4 R7500v2
@@ -194,7 +194,7 @@ define Device/R7800
KERNEL_SIZE := 2097152
NETGEAR_BOARD_ID := R7800
NETGEAR_HW_ID := 29764958+0+128+512+4x4+4x4+cascade
- BLOCKSIZE := 128KiB
+ BLOCKSIZE := 128k
PAGESIZE := 2048
BOARD_NAME := r7800
DEVICE_TITLE := Netgear Nighthawk X4S R7800
diff --git a/target/linux/kirkwood/image/Makefile b/target/linux/kirkwood/image/Makefile
index 91b0495a43..33eaa4f4b2 100644
--- a/target/linux/kirkwood/image/Makefile
+++ b/target/linux/kirkwood/image/Makefile
@@ -26,7 +26,7 @@ define Device/Default
PAGESIZE := 2048
SUBPAGESIZE := 512
- BLOCKSIZE := 128KiB
+ BLOCKSIZE := 128k
IMAGES := sysupgrade.tar
IMAGE/sysupgrade.tar := sysupgrade-tar
endef
diff --git a/target/linux/lantiq/image/Makefile b/target/linux/lantiq/image/Makefile
index 3c7391808d..8e06a99c22 100644
--- a/target/linux/lantiq/image/Makefile
+++ b/target/linux/lantiq/image/Makefile
@@ -187,14 +187,14 @@ endef
DEVICE_VARS += IMAGE_SIZE
define Device/NAND/xway
- BLOCKSIZE := 16KiB
+ BLOCKSIZE := 16k
PAGESIZE := 512
SUBPAGESIZE := 256
FILESYSTEMS += ubifs
endef
define Device/NAND/xrx200
- BLOCKSIZE := 128KiB
+ BLOCKSIZE := 128k
PAGESIZE := 2048
SUBPAGESIZE := 512
FILESYSTEMS += ubifs
diff --git a/target/linux/mvebu/image/Makefile b/target/linux/mvebu/image/Makefile
index 05321e1dc5..3d71e52f5b 100644
--- a/target/linux/mvebu/image/Makefile
+++ b/target/linux/mvebu/image/Makefile
@@ -83,7 +83,7 @@ endef
define Device/NAND-128K
$(Device/UBI)
- BLOCKSIZE := 128KiB
+ BLOCKSIZE := 128k
PAGESIZE := 2048
SUBPAGESIZE := 512
VID_HDR_OFFSET := 2048
@@ -91,13 +91,13 @@ endef
define Device/NAND-256K
$(Device/UBI)
- BLOCKSIZE := 256KiB
+ BLOCKSIZE := 256k
PAGESIZE := 4096
endef
define Device/NAND-512K
$(Device/UBI)
- BLOCKSIZE := 512KiB
+ BLOCKSIZE := 512k
PAGESIZE := 4096
endef
@@ -145,7 +145,7 @@ TARGET_DEVICES += linksys-wrt1900ac
define Device/openblocks-ax3
$(Device/UBI-factory)
DEVICE_DTS := armada-xp-openblocks-ax3-4
- BLOCKSIZE := 128KiB
+ BLOCKSIZE := 128k
PAGESIZE := 1
IMAGE/factory.img := append-kernel $$$$(KERNEL_SIZE) | append-ubi
DEVICE_TITLE := Plat'Home OpenBlocks AX3
diff --git a/target/linux/oxnas/image/Makefile b/target/linux/oxnas/image/Makefile
index bc691de405..6e5bb82e6c 100644
--- a/target/linux/oxnas/image/Makefile
+++ b/target/linux/oxnas/image/Makefile
@@ -29,7 +29,7 @@ define Device/Default
KERNEL_INITRAMFS = kernel-bin | lzma | fit lzma $$(DTS_DIR)/ox820-$$(DTS).dtb | ubootable
KERNEL_INITRAMFS_PREFIX = $$(IMAGE_PREFIX)-u-boot-initramfs
KERNEL_INITRAMFS_SUFFIX := .bin
- BLOCKSIZE := 128KiB
+ BLOCKSIZE := 128k
PAGESIZE := 2048
SUBPAGESIZE := 512
FILESYSTEMS := squashfs ubifs
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index e602dfb409..d1d0aa4390 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -147,11 +147,11 @@ TARGET_DEVICES += zbt-wg3526
define Device/wf-2881
DTS := WF-2881
- BLOCKSIZE := 128KiB
+ BLOCKSIZE := 128k
PAGESIZE := 2048
FILESYSTEMS := squashfs
IMAGE_SIZE := 132382720
- KERNEL := $(KERNEL_DTB) | pad-offset 131072 64 | uImage lzma
+ KERNEL := $(KERNEL_DTB) | pad-offset $$(BLOCKSIZE) 64 | uImage lzma
IMAGE/sysupgrade.bin := append-kernel | append-ubi | check-size $$$$(IMAGE_SIZE)
DEVICE_TITLE := NETIS WF-2881
DEVICE_PACKAGES := kmod-usb3 kmod-ledtrig-usbdev