summaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorTim Harvey <tharvey@gateworks.com>2016-09-08 08:40:03 -0700
committerFelix Fietkau <nbd@nbd.name>2016-09-15 13:11:21 +0200
commitdc17fde99436fd7912914c0e4d3f106820ffe9e8 (patch)
tree9a211e0eb2b16b960488452599e220447395cd1c /target
parenteb88a9cacb41a69cdeb335298882b218361ff825 (diff)
downloadmaster-31e0f0ae-dc17fde99436fd7912914c0e4d3f106820ffe9e8.tar.gz
master-31e0f0ae-dc17fde99436fd7912914c0e4d3f106820ffe9e8.tar.bz2
master-31e0f0ae-dc17fde99436fd7912914c0e4d3f106820ffe9e8.zip
kernel: clean up usb gadget support
clean up usb gadget support: - rename gadget modules so that they appear together and are easier to identify as gadget modules - make usb-lib-composite and usb-gadget hidden as there is no point in selecting those without gadget drivers that require them as deps Signed-off-by: Tim Harvey <tharvey@gateworks.com>
Diffstat (limited to 'target')
-rw-r--r--target/linux/at91/Makefile2
-rw-r--r--target/linux/omap24xx/profiles/100-n810.mk2
2 files changed, 2 insertions, 2 deletions
diff --git a/target/linux/at91/Makefile b/target/linux/at91/Makefile
index 372bf177e4..bf62051d72 100644
--- a/target/linux/at91/Makefile
+++ b/target/linux/at91/Makefile
@@ -17,6 +17,6 @@ KERNEL_PATCHVER:=4.4
include $(INCLUDE_DIR)/target.mk
-DEFAULT_PACKAGES += kmod-usb-ohci kmod-at91-udc kmod-usb-eth-gadget
+DEFAULT_PACKAGES += kmod-usb-ohci kmod-at91-udc kmod-usb-gadget-eth
$(eval $(call BuildTarget))
diff --git a/target/linux/omap24xx/profiles/100-n810.mk b/target/linux/omap24xx/profiles/100-n810.mk
index 36f30866d0..bf2598c61e 100644
--- a/target/linux/omap24xx/profiles/100-n810.mk
+++ b/target/linux/omap24xx/profiles/100-n810.mk
@@ -16,7 +16,7 @@ define Profile/n810-base
kmod-fs-vfat kmod-fs-msdos \
kmod-input-evdev \
kmod-leds-gpio \
- kmod-usb-tahvo kmod-usb-eth-gadget \
+ kmod-usb-tahvo kmod-usb-gadget-eth \
kmod-usb-net kmod-usb-net-cdc-ether kmod-usb-net-pegasus kmod-usb-net-rndis \
kmod-usb-storage kmod-usb-hid \
kmod-bluetooth kmod-bluetooth-hci-h4p bluez-utils bluez-hcidump \