summaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorMathias Kresin <dev@kresin.me>2016-09-08 20:14:42 +0200
committerMathias Kresin <dev@kresin.me>2016-09-08 20:14:42 +0200
commitd7b6f0ea8885b45db4e435846e0fcbd822fcc8ad (patch)
tree4591d2b9167e4ed50431f57c8f06cb6ad8caca3b /target
parent3e7524c184d147de6b0c8154c5c4f4019993922f (diff)
downloadmaster-31e0f0ae-d7b6f0ea8885b45db4e435846e0fcbd822fcc8ad.tar.gz
master-31e0f0ae-d7b6f0ea8885b45db4e435846e0fcbd822fcc8ad.tar.bz2
master-31e0f0ae-d7b6f0ea8885b45db4e435846e0fcbd822fcc8ad.zip
apm821xx: image: add support for k unit suffix to boot-img
Signed-off-by: Mathias Kresin <dev@kresin.me>
Diffstat (limited to 'target')
-rw-r--r--target/linux/apm821xx/image/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/apm821xx/image/Makefile b/target/linux/apm821xx/image/Makefile
index f151543b9c..38877f9bca 100644
--- a/target/linux/apm821xx/image/Makefile
+++ b/target/linux/apm821xx/image/Makefile
@@ -184,7 +184,7 @@ define Build/boot-img
$(CP) $(IMAGE_KERNEL).dtb $@.bootdir/boot/$(DEVICE_DTB)
$(CP) $(IMAGE_KERNEL) $@.bootdir/boot/uImage
- genext2fs --block-size $(BLOCKSIZE) --size-in-blocks $$((1024 * $(BOOT_SIZE))) --root $@.bootdir $@.boot
+ genext2fs --block-size $(BLOCKSIZE:%k=%Ki) --size-in-blocks $$((1024 * $(BOOT_SIZE))) --root $@.bootdir $@.boot
# convert it to revision 1 - needed for u-boot ext2load
$(STAGING_DIR_HOST)/bin/tune2fs -O filetype $@.boot