summaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2016-09-08 14:46:49 +0200
committerFelix Fietkau <nbd@nbd.name>2016-09-10 12:17:39 +0200
commitd2a7df0792020c430477abed244f5b76bb990b7f (patch)
tree4099d5f474ee0274fbc96a62d86f8be652250c9e /target
parent08cf46123fbd132913f278c8089147d259a5cc75 (diff)
downloadmaster-31e0f0ae-d2a7df0792020c430477abed244f5b76bb990b7f.tar.gz
master-31e0f0ae-d2a7df0792020c430477abed244f5b76bb990b7f.tar.bz2
master-31e0f0ae-d2a7df0792020c430477abed244f5b76bb990b7f.zip
octeon: use new ext4/f2fs overlay support
Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'target')
-rw-r--r--target/linux/octeon/image/Makefile7
1 files changed, 3 insertions, 4 deletions
diff --git a/target/linux/octeon/image/Makefile b/target/linux/octeon/image/Makefile
index ab91d066c6..62e55dcf5d 100644
--- a/target/linux/octeon/image/Makefile
+++ b/target/linux/octeon/image/Makefile
@@ -13,9 +13,8 @@ define Device/Default
KERNEL_INITRAMFS_NAME := vmlinux-initramfs.elf
KERNEL := kernel-bin | strip-kernel | patch-cmdline
IMAGES := sysupgrade.tar
- IMAGE/sysupgrade.tar/squashfs := append-rootfs | pad-rootfs | sysupgrade-tar rootfs=$$$$@
+ IMAGE/sysupgrade.tar/squashfs := append-rootfs | pad-extra 128k | sysupgrade-tar rootfs=$$$$@
IMAGE/sysupgrade.tar := sysupgrade-tar
- FILESYSTEMS := squashfs
endef
define Build/strip-kernel
@@ -29,14 +28,14 @@ define Device/generic
endef
TARGET_DEVICES += generic
-ER_CMDLINE:=-mtdparts=phys_mapped_flash:640k(boot0)ro,640k(boot1)ro,64k(eeprom)ro block2mtd.block2mtd=/dev/mmcblk0p2,65536,rootfs,15 root=/dev/mtdblock3 rootfstype=squashfs rootwait
+ER_CMDLINE:=-mtdparts=phys_mapped_flash:640k(boot0)ro,640k(boot1)ro,64k(eeprom)ro root=/dev/mmcblk0p2 rootfstype=squashfs,ext4 rootwait
define Device/er
CMDLINE := $(ER_CMDLINE)
DEVICE_TITLE := Ubiquiti EdgeRouter
endef
TARGET_DEVICES += er
-ERLITE_CMDLINE:=-mtdparts=phys_mapped_flash:512k(boot0),512k(boot1),64k@1024k(eeprom) block2mtd.block2mtd=/dev/sda2,65536,rootfs,5 root=/dev/mtdblock3 rootfstype=squashfs rootwait
+ERLITE_CMDLINE:=-mtdparts=phys_mapped_flash:512k(boot0),512k(boot1),64k@1024k(eeprom) root=/dev/sda2 rootfstype=squashfs,ext4 rootwait
define Device/erlite
CMDLINE := $(ERLITE_CMDLINE)
DEVICE_TITLE := Ubiquiti EdgeRouter Lite