summaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2016-09-08 13:40:12 +0200
committerFelix Fietkau <nbd@nbd.name>2016-09-10 12:17:39 +0200
commitbe59b1718debd441833542f11a8c01e848bf6fbb (patch)
treebd569b4d6edffc13bfa3fd5264dcaf82af673395 /target
parentc6eb09d5a327a43e92ee7f4df2e8002e7259bebd (diff)
downloadmaster-31e0f0ae-be59b1718debd441833542f11a8c01e848bf6fbb.tar.gz
master-31e0f0ae-be59b1718debd441833542f11a8c01e848bf6fbb.tar.bz2
master-31e0f0ae-be59b1718debd441833542f11a8c01e848bf6fbb.zip
x86: drop the use of block2mtd, use ext4/f2fs as overlay filesystem
Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'target')
-rw-r--r--target/linux/x86/image/Makefile18
1 files changed, 2 insertions, 16 deletions
diff --git a/target/linux/x86/image/Makefile b/target/linux/x86/image/Makefile
index 602ea7e195..a210c902e5 100644
--- a/target/linux/x86/image/Makefile
+++ b/target/linux/x86/image/Makefile
@@ -54,16 +54,8 @@ ifneq ($(CONFIG_GRUB_IMAGES),)
root=$(ROOTPART) rootfstype=ext4 rootwait
endef
- define Image/cmdline/jffs2-64k
- block2mtd.block2mtd=$(ROOTPART),65536,rootfs,5 root=/dev/mtdblock0 rootfstype=jffs2 rootwait
- endef
-
- define Image/cmdline/jffs2-128k
- block2mtd.block2mtd=$(ROOTPART),131072,rootfs,5 root=/dev/mtdblock0 rootfstype=jffs2 rootwait
- endef
-
define Image/cmdline/squashfs
- block2mtd.block2mtd=$(ROOTPART),65536,rootfs,5 root=/dev/mtdblock0 rootfstype=squashfs rootwait
+ root=$(ROOTPART) rootfstype=squashfs rootwait
endef
define Image/Build/grub2
@@ -101,7 +93,7 @@ endif
ROOTDELAY=10
define Image/Build/squashfs
- $(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
+ dd if=/dev/zero bs=128k count=1 >> $(KDIR)/root.squashfs
endef
define Image/Build/iso
@@ -161,12 +153,6 @@ ifneq ($(CONFIG_TARGET_IMAGES_GZIP),)
define Image/Build/gzip/squashfs
$(call Image/Build/gzip,squashfs)
endef
- define Image/Build/gzip/jffs2-64k
- $(call Image/Build/gzip,jffs2-64k)
- endef
- define Image/Build/gzip/jffs2-128k
- $(call Image/Build/gzip,jffs2-128k)
- endef
endif
endif