summaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorMathias Kresin <dev@kresin.me>2016-09-04 09:58:02 +0200
committerMathias Kresin <dev@kresin.me>2016-09-04 09:58:02 +0200
commita499d0a6b55715070f65b72b25436530c3909135 (patch)
tree257e361e18183255f801839c783222caa4a7c4d4 /target
parente7ec7a08aae0afb1064d1bf26a9cd6fe1e64d516 (diff)
downloadmaster-31e0f0ae-a499d0a6b55715070f65b72b25436530c3909135.tar.gz
master-31e0f0ae-a499d0a6b55715070f65b72b25436530c3909135.tar.bz2
master-31e0f0ae-a499d0a6b55715070f65b72b25436530c3909135.zip
image: specify max image size in Kilobyte/Megabyte
Use the k and m unit suffix to be consistent with the blocksize. Signed-off-by: Mathias Kresin <dev@kresin.me>
Diffstat (limited to 'target')
-rw-r--r--target/linux/apm821xx/image/Makefile4
-rw-r--r--target/linux/ramips/image/mt7620.mk26
-rw-r--r--target/linux/ramips/image/mt7621.mk2
-rw-r--r--target/linux/ramips/image/rt288x.mk3
-rw-r--r--target/linux/ramips/image/rt305x.mk32
5 files changed, 24 insertions, 43 deletions
diff --git a/target/linux/apm821xx/image/Makefile b/target/linux/apm821xx/image/Makefile
index 3ec8ae0cee..607df061f1 100644
--- a/target/linux/apm821xx/image/Makefile
+++ b/target/linux/apm821xx/image/Makefile
@@ -152,7 +152,7 @@ define Device/WNDR4700
SUBPAGESIZE := 512
BLOCKSIZE := 128k
DTB_SIZE := 131008
- IMAGE_SIZE:=25559040
+ IMAGE_SIZE := 24960k
IMAGES := factory.img sysupgrade.tar
KERNEL_SIZE := 1920k
KERNEL := dtb | kernel-bin | lzma | uImage lzma | pad-offset $$(BLOCKSIZE) 64 | append-fakerootfs
@@ -220,7 +220,7 @@ endef
define Device/MyBookLiveDefault
IMAGE_SIZE := 48m
- BLOCKSIZE := 1024
+ BLOCKSIZE := 1k
DTB_SIZE := 16384
KERNEL := kernel-bin | dtb | gzip | uImage gzip
BOOT_SIZE := 8
diff --git a/target/linux/ramips/image/mt7620.mk b/target/linux/ramips/image/mt7620.mk
index 00dd4f20bd..ccf67a1ce9 100644
--- a/target/linux/ramips/image/mt7620.mk
+++ b/target/linux/ramips/image/mt7620.mk
@@ -64,10 +64,9 @@ define Device/ArcherC50
endef
TARGET_DEVICES += ArcherC50
-ex2700_mtd_size=3866624
define Device/ex2700
DTS := EX2700
- IMAGE_SIZE := $(ex2700_mtd_size)
+ IMAGE_SIZE := $(ralink_default_fw_size_4M)
IMAGES += factory.bin
KERNEL := $(KERNEL_DTB) | uImage lzma | pad-kernel-ex2700
IMAGE/factory.bin := $$(IMAGE/sysupgrade.bin) | netgear-header -B EX2700 -H 29764623+4+0+32+2x2+0
@@ -111,58 +110,52 @@ define Device/e1700
endef
TARGET_DEVICES += e1700
-br100_mtd_size=8126464
define Device/ai-br100
DTS := AI-BR100
- IMAGE_SIZE := $(br100_mtd_size)
+ IMAGE_SIZE := 7936k
DEVICE_TITLE := Aigale Ai-BR100
DEVICE_PACKAGES:= kmod-usb2 kmod-usb-ohci
endef
TARGET_DEVICES += ai-br100
-whr_300hp2_mtd_size=7012352
define Device/whr-300hp2
DTS := WHR-300HP2
- IMAGE_SIZE := $(whr_300hp2_mtd_size)
+ IMAGE_SIZE := 6848k
DEVICE_TITLE := Buffalo WHR-300HP2
endef
TARGET_DEVICES += whr-300hp2
define Device/whr-600d
DTS := WHR-600D
- IMAGE_SIZE := $(whr_300hp2_mtd_size)
+ IMAGE_SIZE := 6848k
DEVICE_TITLE := Buffalo WHR-600D
endef
TARGET_DEVICES += whr-600d
-whr_1166d_mtd_size=15400960
define Device/whr-1166d
DTS := WHR-1166D
- IMAGE_SIZE := $(whr_1166d_mtd_size)
+ IMAGE_SIZE := 15040k
DEVICE_TITLE := Buffalo WHR-1166D
endef
TARGET_DEVICES += whr-1166d
-dlink810l_mtd_size=6881280
define Device/dir-810l
DTS := DIR-810L
- IMAGE_SIZE := $(dlink810l_mtd_size)
+ IMAGE_SIZE := 6720k
DEVICE_TITLE := D-Link DIR-810L
endef
TARGET_DEVICES += dir-810l
-na930_mtd_size=20971520
define Device/na930
DTS := NA930
- IMAGE_SIZE := $(na930_mtd_size)
+ IMAGE_SIZE := 20m
DEVICE_TITLE := Sercomm NA930
endef
TARGET_DEVICES += na930
-microwrt_mtd_size=16515072
define Device/microwrt
DTS := MicroWRT
- IMAGE_SIZE := $(microwrt_mtd_size)
+ IMAGE_SIZE := 16128k
DEVICE_TITLE := Microduino MicroWRT
endef
TARGET_DEVICES += microwrt
@@ -419,11 +412,10 @@ define Device/tiny-ac
endef
TARGET_DEVICES += tiny-ac
-dch_m225_mtd_size=7012352
define Device/dch-m225
DTS := DCH-M225
IMAGES += factory.bin
- IMAGE_SIZE := $(dch_m225_mtd_size)
+ IMAGE_SIZE := 6848k
IMAGE/sysupgrade.bin := \
append-kernel | pad-offset 65536 64 | append-rootfs | \
seama -m "dev=/dev/mtdblock/2" -m "type=firmware" | \
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index d1d0aa4390..750e7e1e4b 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -150,7 +150,7 @@ define Device/wf-2881
BLOCKSIZE := 128k
PAGESIZE := 2048
FILESYSTEMS := squashfs
- IMAGE_SIZE := 132382720
+ IMAGE_SIZE := 129280k
KERNEL := $(KERNEL_DTB) | pad-offset $$(BLOCKSIZE) 64 | uImage lzma
IMAGE/sysupgrade.bin := append-kernel | append-ubi | check-size $$$$(IMAGE_SIZE)
DEVICE_TITLE := NETIS WF-2881
diff --git a/target/linux/ramips/image/rt288x.mk b/target/linux/ramips/image/rt288x.mk
index 2bdb18ec83..ebb523e461 100644
--- a/target/linux/ramips/image/rt288x.mk
+++ b/target/linux/ramips/image/rt288x.mk
@@ -31,10 +31,9 @@ define Device/ar725w
endef
TARGET_DEVICES += ar725w
-belkin_f5d8235v1_mtd_size=7929856
define Device/f5d8235v1
DTS := F5D8235_V1
- IMAGE_SIZE := $(belkin_f5d8235v1_mtd_size)
+ IMAGE_SIZE := 7744k
DEVICE_TITLE := Belkin F5D8235 V1
DEVICE_PACKAGES := kmod-switch-rtl8366s
endef
diff --git a/target/linux/ramips/image/rt305x.mk b/target/linux/ramips/image/rt305x.mk
index 77559a2bd3..8525db191a 100644
--- a/target/linux/ramips/image/rt305x.mk
+++ b/target/linux/ramips/image/rt305x.mk
@@ -2,50 +2,45 @@
# RT305X Profiles
#
-asl26555_8mb_mtd_size=7929856
define Device/asl26555-8M
DTS := ASL26555-8M
- IMAGE_SIZE := $(asl26555_8mb_mtd_size)
+ IMAGE_SIZE := 7744k
DEVICE_TITLE := Alpha ASL26555
DEVICE_PACKAGES := kmod-usb-core kmod-usb-dwc2 kmod-ledtrig-usbdev
endef
TARGET_DEVICES += asl26555-8M
-asl26555_16mb_mtd_size=16252928
define Device/asl26555-16M
DTS := ASL26555-16M
- IMAGE_SIZE := $(asl26555_16mb_mtd_size)
+ IMAGE_SIZE := 15872k
DEVICE_TITLE := Alpha ASL26555 16M
DEVICE_PACKAGES :=
endef
TARGET_DEVICES += asl26555-16M
-nixcore_8mb_mtd_size=8060928
define Device/nixcore-8M
DTS := NIXCORE-8M
- IMAGE_SIZE := $(nixcore_8mb_mtd_size)
+ IMAGE_SIZE := 7872k
DEVICE_TITLE := NixcoreX1 8M
DEVICE_PACKAGES := kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-i2c-core kmod-i2c-ralink kmod-spi-dev
endef
TARGET_DEVICES += nixcore-8M
-nixcore_16mb_mtd_size=16449536
define Device/nixcore-16M
DTS := NIXCORE-16M
- IMAGE_SIZE := $(nixcore_16mb_mtd_size)
+ IMAGE_SIZE := 16064k
DEVICE_TITLE := NixcoreX1 16M
DEVICE_PACKAGES := kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-i2c-core kmod-i2c-ralink kmod-spi-dev
endef
TARGET_DEVICES += nixcore-16M
-vocore_8mb_mtd_size=8060928
define Device/vocore-8M
DTS := VOCORE-8M
- IMAGE_SIZE := $(vocore_8mb_mtd_size)
+ IMAGE_SIZE := 7872k
DEVICE_TITLE := VoCore 8M
DEVICE_PACKAGES := kmod-usb-core kmod-usb-ohci kmod-usb2 \
kmod-i2c-core kmod-i2c-ralink \
@@ -54,10 +49,9 @@ endef
TARGET_DEVICES += vocore-8M
-vocore_16mb_mtd_size=16449536
define Device/vocore-16M
DTS := VOCORE-16M
- IMAGE_SIZE := $(vocore_16mb_mtd_size)
+ IMAGE_SIZE := 16064k
DEVICE_TITLE := VoCore 16M
DEVICE_PACKAGES := kmod-usb-core kmod-usb-ohci kmod-usb2 \
kmod-i2c-core kmod-i2c-ralink \
@@ -66,10 +60,9 @@ endef
TARGET_DEVICES += vocore-16M
-allnet_all5002_mtd_size=33226752
define Device/all5002
DTS := ALL5002
- IMAGE_SIZE := $(allnet_all5002_mtd_size)
+ IMAGE_SIZE := 32448k
DEVICE_TITLE := Allnet ALL5002
DEVICE_PACKAGES := kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-ledtrig-usbdev \
kmod-i2c-core kmod-i2c-gpio kmod-hwmon-lm92 kmod-gpio-pcf857x
@@ -79,7 +72,7 @@ TARGET_DEVICES += all5002
define Device/all5003
DTS := ALL5003
- IMAGE_SIZE := $(allnet_all5002_mtd_size)
+ IMAGE_SIZE := 32448k
DEVICE_TITLE := Allnet ALL5003
DEVICE_PACKAGES := kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-ledtrig-usbdev \
kmod-i2c-core kmod-i2c-gpio kmod-hwmon-lm92 kmod-gpio-pcf857x
@@ -87,28 +80,25 @@ endef
TARGET_DEVICES += all5003
-argus_atp52b_mtd_size=7995392
define Device/atp-52b
DTS := ATP-52B
- IMAGE_SIZE := $(argus_atp52b_mtd_size)
+ IMAGE_SIZE := 7808k
DEVICE_TITLE := Argus ATP-52B
endef
TARGET_DEVICES += atp-52b
-belkin_f5d8235v2_mtd_size=7929856
define Device/f5d8235v2
DTS := F5D8235_V2
- IMAGE_SIZE := $(belkin_f5d8235v2_mtd_size)
+ IMAGE_SIZE := 7744k
DEVICE_TITLE := Belkin F5D8235 v2
endef
TARGET_DEVICES += f5d8235v2
-belkin_f7c027_mtd_size=7798784
define Device/f7c027
DTS := F7C027
- IMAGE_SIZE := $(belkin_f7c027_mtd_size)
+ IMAGE_SIZE := 7616k
DEVICE_TITLE := Belkin F7C027
DEVICE_PACKAGES := -kmod-usb-core -kmod-usb-dwc2 -kmod-ledtrig-usbdev
endef