summaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-05-23 15:27:05 +0000
committerJohn Crispin <john@openwrt.org>2015-05-23 15:27:05 +0000
commit9c86abae0e22107ed10fad76b568190ac3f2a6ca (patch)
tree1737255ed5e064d0696e621eb74dbcdc04d104f4 /target
parent4810f3f8037389d2efe0c4ea750ec7d6218d5902 (diff)
downloadmaster-31e0f0ae-9c86abae0e22107ed10fad76b568190ac3f2a6ca.tar.gz
master-31e0f0ae-9c86abae0e22107ed10fad76b568190ac3f2a6ca.tar.bz2
master-31e0f0ae-9c86abae0e22107ed10fad76b568190ac3f2a6ca.zip
ramips: Adding support for AXIMCom MR-102N 3G/4G Travel Mobile Router
MR-102N is a RT3050F based wireless router(32M RAM + 8M NOR flash) with 1 USB and 1 ethernet port. The original product information can be found at: http://www.aximcom.com/en/MR-102N Signed-off-by: Tai-hwa Liang <atliang@gmail.com> SVN-Revision: 45724
Diffstat (limited to 'target')
-rwxr-xr-xtarget/linux/ramips/base-files/etc/board.d/01_leds4
-rwxr-xr-xtarget/linux/ramips/base-files/etc/board.d/02_network3
-rw-r--r--target/linux/ramips/base-files/etc/diag.sh3
-rwxr-xr-xtarget/linux/ramips/base-files/lib/ramips.sh3
-rwxr-xr-xtarget/linux/ramips/base-files/lib/upgrade/platform.sh1
-rw-r--r--target/linux/ramips/dts/MR-102N.dts111
-rw-r--r--target/linux/ramips/image/Makefile3
-rw-r--r--target/linux/ramips/rt305x/profiles/aximcom.mk17
8 files changed, 144 insertions, 1 deletions
diff --git a/target/linux/ramips/base-files/etc/board.d/01_leds b/target/linux/ramips/base-files/etc/board.d/01_leds
index 80623f4a8d..ad0062a56b 100755
--- a/target/linux/ramips/base-files/etc/board.d/01_leds
+++ b/target/linux/ramips/base-files/etc/board.d/01_leds
@@ -145,6 +145,10 @@ case $board in
mpr-a2)
set_wifi_led "hame:blue:system"
;;
+ mr-102n)
+ set_wifi_led "mr-102n:green:wlan"
+ set_usb_led "mr-102n:green:usb"
+ ;;
mzk-w300nh2)
set_wifi_led "mzkw300nh2:amber:wlan"
;;
diff --git a/target/linux/ramips/base-files/etc/board.d/02_network b/target/linux/ramips/base-files/etc/board.d/02_network
index c8ef69f2c0..43a0e54f73 100755
--- a/target/linux/ramips/base-files/etc/board.d/02_network
+++ b/target/linux/ramips/base-files/etc/board.d/02_network
@@ -61,7 +61,8 @@ ramips_setup_interfaces()
;;
3g-6200nl | \
- mlw221)
+ mlw221 | \
+ mr-102n)
ucidef_set_interface_lan "eth0.2"
;;
mlwg2)
diff --git a/target/linux/ramips/base-files/etc/diag.sh b/target/linux/ramips/base-files/etc/diag.sh
index caede7bcc8..6bba7e4394 100644
--- a/target/linux/ramips/base-files/etc/diag.sh
+++ b/target/linux/ramips/base-files/etc/diag.sh
@@ -104,6 +104,9 @@ get_status_led() {
mpr-a2)
status_led="hame:red:power"
;;
+ mr-102n)
+ status_led="mr-102n:amber:status"
+ ;;
nbg-419n)
status_led="nbg-419n:green:power"
;;
diff --git a/target/linux/ramips/base-files/lib/ramips.sh b/target/linux/ramips/base-files/lib/ramips.sh
index 5769d26c2c..cd4e39c5f7 100755
--- a/target/linux/ramips/base-files/lib/ramips.sh
+++ b/target/linux/ramips/base-files/lib/ramips.sh
@@ -85,6 +85,9 @@ ramips_board_detect() {
*"Aztech HW550-3G")
name="hw550-3g"
;;
+ *"AXIMCom MR-102N")
+ name="mr-102n"
+ ;;
*"Buffalo WSR-600DHP")
name="wsr-600"
;;
diff --git a/target/linux/ramips/base-files/lib/upgrade/platform.sh b/target/linux/ramips/base-files/lib/upgrade/platform.sh
index 4ecf3314dc..0a54d3747c 100755
--- a/target/linux/ramips/base-files/lib/upgrade/platform.sh
+++ b/target/linux/ramips/base-files/lib/upgrade/platform.sh
@@ -67,6 +67,7 @@ platform_check_image() {
mofi3500-3gn | \
mpr-a1 | \
mpr-a2 | \
+ mr-102n | \
mzk-w300nh2 | \
nbg-419n | \
nw718 | \
diff --git a/target/linux/ramips/dts/MR-102N.dts b/target/linux/ramips/dts/MR-102N.dts
new file mode 100644
index 0000000000..c2a6e24370
--- /dev/null
+++ b/target/linux/ramips/dts/MR-102N.dts
@@ -0,0 +1,111 @@
+/dts-v1/;
+
+/include/ "rt3050.dtsi"
+
+/ {
+ compatible = "MR-102N", "ralink,rt3052-soc";
+ model = "AXIMCom MR-102N";
+
+ pinctrl {
+ state_default: pinctrl0 {
+ gpio {
+ ralink,group = "i2c", "jtag", "rgmii", "mdio", "uartf";
+ ralink,function = "gpio";
+ };
+ };
+ };
+
+ cfi@1f000000 {
+ compatible = "cfi-flash";
+ reg = <0x1f000000 0x800000>;
+
+ bank-width = <2>;
+ device-width = <2>;
+ #address-cells = <1>;
+ #size-cells = <1>;
+
+ partition@0 {
+ label = "u-boot";
+ reg = <0x0 0x30000>;
+ read-only;
+ };
+
+ partition@30000 {
+ label = "u-boot-env";
+ reg = <0x30000 0x10000>;
+ read-only;
+ };
+
+ factory: partition@40000 {
+ label = "factory";
+ reg = <0x40000 0x10000>;
+ read-only;
+ };
+
+ partition@50000 {
+ label = "firmware";
+ reg = <0x50000 0x790000>;
+ };
+
+ partition@7e0000 {
+ label = "nvram";
+ reg = <0x7e0000 0x10000>;
+ };
+
+ partition@7f0000 {
+ label = "nvram_backup";
+ reg = <0x7f0000 0x10000>;
+ };
+ };
+
+ ethernet@10100000 {
+ mtd-mac-address = <&factory 0x4>;
+ };
+
+ esw@10110000 {
+ status = "okay";
+ #ralink,portmap = <0x3e>;
+ ralink,portmap = <0x2f>;
+ };
+
+ wmac@10180000 {
+ ralink,mtd-eeprom = <&factory 0>;
+ };
+
+ gpio-leds {
+ compatible = "gpio-leds";
+ usb {
+ label = "mr-102n:green:usb";
+ gpios = <&gpio0 8 1>;
+ };
+ status {
+ label = "mr-102n:amber:status";
+ gpios = <&gpio0 9 1>;
+ };
+ wlan {
+ label = "mr-102n:green:wlan";
+ gpios = <&gpio0 11 1>;
+ };
+ };
+
+ gpio-keys-polled {
+ compatible = "gpio-keys-polled";
+ #address-cells = <1>;
+ #size-cells = <0>;
+ poll-interval = <20>;
+ reset {
+ label = "reset";
+ gpios = <&gpio0 13 1>;
+ linux,code = <0x198>;
+ };
+ wps {
+ label = "wps";
+ gpios = <&gpio0 18 1>;
+ linux,code = <0x211>;
+ };
+ };
+
+ otg@101c0000 {
+ status = "okay";
+ };
+};
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index 2f4fdf16ed..b0b35796a7 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -554,6 +554,8 @@ Image/Build/Profile/MOFI3500-3GN=$(call BuildFirmware/Default8M/$(1),$(1),mofi35
# Kernel name should be "Linux Kernel Image" to make the OpenWrt image installable from factory Web UI
Image/Build/Profile/3G150B=$(call BuildFirmware/Default4M/$(1),$(1),3g150b,3G150B,Linux Kernel Image)
+Image/Build/Profile/MR102N=$(call BuildFirmware/Default8M/$(1),$(1),mr-102n,MR-102N)
+
Image/Build/Profile/MPRA1=$(call BuildFirmware/Default4M/$(1),$(1),mpr-a1,MPRA1,Linux Kernel Image)
Image/Build/Profile/MPRA2=$(call BuildFirmware/Default8M/$(1),$(1),mpr-a2,MPRA2,Linux Kernel Image)
@@ -724,6 +726,7 @@ define Image/Build/Profile/Default
$(call Image/Build/Profile/M3,$(1))
$(call Image/Build/Profile/M4,$(1))
$(call Image/Build/Profile/MOFI3500-3GN,$(1))
+ $(call Image/Build/Profile/MR102N,$(1))
$(call Image/Build/Profile/MPRA1,$(1))
$(call Image/Build/Profile/MPRA2,$(1))
$(call Image/Build/Profile/MZKW300NH2,$(1))
diff --git a/target/linux/ramips/rt305x/profiles/aximcom.mk b/target/linux/ramips/rt305x/profiles/aximcom.mk
new file mode 100644
index 0000000000..eb305af6e4
--- /dev/null
+++ b/target/linux/ramips/rt305x/profiles/aximcom.mk
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/MR102N
+ NAME:=AXIMCom MR-102N
+ PACKAGES:=kmod-usb-core kmod-usb-dwc2 kmod-ledtrig-usbdev
+endef
+
+define Profile/MR102N/Description
+ Package set for AXIMCom MR-102N
+endef
+
+$(eval $(call Profile,MR102N))