summaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2013-12-25 17:04:50 +0000
committerJohn Crispin <john@openwrt.org>2013-12-25 17:04:50 +0000
commit9739a0b41baa88c233f76b93ac01805b7b635d94 (patch)
tree5bc94f89835ff88e1d8aa61d66236febd0475f15 /target
parent93d8dc870ee07027ca1e27f19831d6127402336f (diff)
downloadmaster-31e0f0ae-9739a0b41baa88c233f76b93ac01805b7b635d94.tar.gz
master-31e0f0ae-9739a0b41baa88c233f76b93ac01805b7b635d94.tar.bz2
master-31e0f0ae-9739a0b41baa88c233f76b93ac01805b7b635d94.zip
ramips: add support for RT-N14U (mt7620n based) board
added dts file and userspace scripts modified to support Asus RT-N14U board current support status: usb works ethernet works buttons reset, wps leds asus:blue:[usb|lan|wan|air|power] i2c not tested uart not tested wifi not yet Signed-off-by: Pavel Löbl <lobl.pavel@gmail.com> SVN-Revision: 39163
Diffstat (limited to 'target')
-rwxr-xr-xtarget/linux/ramips/base-files/etc/uci-defaults/01_leds7
-rwxr-xr-xtarget/linux/ramips/base-files/etc/uci-defaults/02_network1
-rwxr-xr-xtarget/linux/ramips/base-files/lib/ramips.sh3
-rwxr-xr-xtarget/linux/ramips/base-files/lib/upgrade/platform.sh1
-rw-r--r--target/linux/ramips/dts/RT-N14U.dts118
-rw-r--r--target/linux/ramips/image/Makefile2
6 files changed, 132 insertions, 0 deletions
diff --git a/target/linux/ramips/base-files/etc/uci-defaults/01_leds b/target/linux/ramips/base-files/etc/uci-defaults/01_leds
index 44951d8e23..fe22875596 100755
--- a/target/linux/ramips/base-files/etc/uci-defaults/01_leds
+++ b/target/linux/ramips/base-files/etc/uci-defaults/01_leds
@@ -141,6 +141,13 @@ case $board in
wnce2001)
set_wifi_led "netgear:green:wlan"
;;
+ rt-n14u)
+ ucidef_set_led_default "power" "power" "asus:blue:power" "1"
+ ucidef_set_led_netdev "lan" "lan" "asus:blue:lan" "eth0.1"
+ ucidef_set_led_netdev "wan" "wan" "asus:blue:wan" "eth0.2"
+ set_wifi_led "asus:blue:air"
+ set_usb_led "asus:blue:usb"
+ ;;
rp-n53)
ucidef_set_led_netdev "eth" "Network" "asus:white:back" "eth0"
set_wifi_led "asus:blue:wifi"
diff --git a/target/linux/ramips/base-files/etc/uci-defaults/02_network b/target/linux/ramips/base-files/etc/uci-defaults/02_network
index 63458eda0a..a9914fdb87 100755
--- a/target/linux/ramips/base-files/etc/uci-defaults/02_network
+++ b/target/linux/ramips/base-files/etc/uci-defaults/02_network
@@ -87,6 +87,7 @@ ramips_setup_interfaces()
f5d8235-v1 | \
f5d8235-v2 | \
hg255d | \
+ rt-n14u | \
ur-326n4g)
ucidef_set_interfaces_lan_wan "eth0.1" "eth0.2"
ucidef_add_switch "switch0" "1" "1"
diff --git a/target/linux/ramips/base-files/lib/ramips.sh b/target/linux/ramips/base-files/lib/ramips.sh
index 972f41534f..d62002ea7c 100755
--- a/target/linux/ramips/base-files/lib/ramips.sh
+++ b/target/linux/ramips/base-files/lib/ramips.sh
@@ -127,6 +127,9 @@ ramips_board_detect() {
*"La Fonera 2.0N")
name="fonera20n"
;;
+ *"Asus RT-N14U")
+ name="rt-n14u"
+ ;;
*"Asus RT-N13U")
name="rt-n13u"
;;
diff --git a/target/linux/ramips/base-files/lib/upgrade/platform.sh b/target/linux/ramips/base-files/lib/upgrade/platform.sh
index 6836e16d96..babeaf2180 100755
--- a/target/linux/ramips/base-files/lib/upgrade/platform.sh
+++ b/target/linux/ramips/base-files/lib/upgrade/platform.sh
@@ -63,6 +63,7 @@ platform_check_image() {
rp-n53 | \
rt-g32-b1 | \
rt-n10-plus | \
+ rt-n14u | \
rt-n15 | \
rt-n56u | \
sl-r7205 | \
diff --git a/target/linux/ramips/dts/RT-N14U.dts b/target/linux/ramips/dts/RT-N14U.dts
new file mode 100644
index 0000000000..d95365bc0e
--- /dev/null
+++ b/target/linux/ramips/dts/RT-N14U.dts
@@ -0,0 +1,118 @@
+/dts-v1/;
+
+/include/ "mt7620n.dtsi"
+
+/ {
+ compatible = "asus,rt-n14u", "ralink,mt7620n-soc";
+ model = "Asus RT-N14U";
+
+ palmbus@10000000 {
+ gpio2: gpio@660 {
+ status = "okay";
+ };
+
+ gpio3: gpio@688 {
+ status = "okay";
+ };
+
+ spi@b00 {
+ status = "okay";
+
+ m25p80@0 {
+ #address-cells = <1>;
+ #size-cells = <1>;
+ #compatible = "mx25l6405d";
+ compatible = "w25q128";
+ reg = <0 0>;
+ linux,modalias = "m25p80", "w25q128";
+ spi-max-frequency = <10000000>;
+
+ partition@0 {
+ label = "u-boot";
+ reg = <0x0 0x30000>;
+ read-only;
+ };
+
+ partition@30000 {
+ label = "u-boot-env";
+ reg = <0x30000 0x10000>;
+ read-only;
+ };
+
+ factory: partition@40000 {
+ label = "factory";
+ reg = <0x40000 0x10000>;
+ read-only;
+ };
+
+ partition@50000 {
+ label = "firmware";
+ reg = <0x50000 0xfb0000>;
+ };
+ };
+ };
+ };
+
+ ehci@101c0000 {
+ status = "okay";
+ };
+
+ ohci@101c1000 {
+ status = "okay";
+ };
+
+ ethernet@10100000 {
+ mtd-mac-address = <&factory 0x4>;
+ ralink,port-map = "wllll";
+ };
+
+ pinctrl {
+ state_default: pinctrl0 {
+ default {
+ ralink,group = "ephy", "wled";
+ ralink,function = "gpio";
+ };
+ };
+ };
+
+ gpio-leds {
+ compatible = "gpio-leds";
+ wan {
+ label = "asus:blue:wan";
+ gpios = <&gpio2 0 1>;
+ };
+ lan {
+ label = "asus:blue:lan";
+ gpios = <&gpio2 1 1>;
+ };
+ usb {
+ label = "asus:blue:usb";
+ gpios = <&gpio2 2 1>;
+ };
+ power {
+ label = "asus:blue:power";
+ gpios = <&gpio2 3 1>;
+ };
+ air {
+ label = "asus:blue:air";
+ gpios = <&gpio3 0 1>;
+ };
+ };
+
+ gpio-keys-polled {
+ compatible = "gpio-keys-polled";
+ #address-cells = <1>;
+ #size-cells = <0>;
+ poll-interval = <20>;
+ reset {
+ label = "reset";
+ gpios = <&gpio0 1 1>;
+ linux,code = <0x198>;
+ };
+ wps {
+ label = "wps";
+ gpios = <&gpio0 2 1>;
+ linux,code = <0x211>;
+ };
+ };
+};
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index 82addb27f8..2d4395dca4 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -646,10 +646,12 @@ endif
#
Image/Build/Profile/WMR300=$(call BuildFirmware/Default8M/$(1),$(1),wmr-300,WMR300)
+Image/Build/Profile/RT-N14U=$(call BuildFirmware/Default8M/$(1),$(1),rt-n14u,RT-N14U)
ifeq ($(SUBTARGET),mt7620n)
define Image/Build/Profile/Default
$(call Image/Build/Profile/WMR300,$(1))
+ $(call Image/Build/Profile/RT-N14U,$(1))
endef
endif