summaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorMathias Kresin <dev@kresin.me>2016-09-09 21:10:54 +0200
committerMathias Kresin <dev@kresin.me>2016-09-10 15:30:38 +0200
commit92eaf27c62cad5f9832dc7084e1ae14d5e7b47e6 (patch)
treef9de469c84f99c0ca221aedd539531500b522210 /target
parent0f6d0afa1391dfe74d790a9637b9bbbbaebeb2fb (diff)
downloadmaster-31e0f0ae-92eaf27c62cad5f9832dc7084e1ae14d5e7b47e6.tar.gz
master-31e0f0ae-92eaf27c62cad5f9832dc7084e1ae14d5e7b47e6.tar.bz2
master-31e0f0ae-92eaf27c62cad5f9832dc7084e1ae14d5e7b47e6.zip
use immediate set in target Makefiles
No functional change, it's just to have the same style everywhere. This way I don't need to use any regex magic to extract all subtargets for compile tests. Signed-off-by: Mathias Kresin <dev@kresin.me>
Diffstat (limited to 'target')
-rw-r--r--target/linux/ar71xx/Makefile2
-rw-r--r--target/linux/au1000/Makefile2
-rw-r--r--target/linux/ixp4xx/Makefile2
-rw-r--r--target/linux/lantiq/Makefile2
-rw-r--r--target/linux/mpc85xx/Makefile2
-rw-r--r--target/linux/x86/Makefile2
-rw-r--r--target/linux/xburst/Makefile2
7 files changed, 7 insertions, 7 deletions
diff --git a/target/linux/ar71xx/Makefile b/target/linux/ar71xx/Makefile
index c0d867c1d9..a8df2b036e 100644
--- a/target/linux/ar71xx/Makefile
+++ b/target/linux/ar71xx/Makefile
@@ -10,7 +10,7 @@ ARCH:=mips
BOARD:=ar71xx
BOARDNAME:=Atheros AR7xxx/AR9xxx
FEATURES:=mips16
-CPU_TYPE=24kc
+CPU_TYPE:=24kc
SUBTARGETS:=generic nand mikrotik
KERNEL_PATCHVER:=4.4
diff --git a/target/linux/au1000/Makefile b/target/linux/au1000/Makefile
index 0e019a9d67..debc41e978 100644
--- a/target/linux/au1000/Makefile
+++ b/target/linux/au1000/Makefile
@@ -10,7 +10,7 @@ ARCH:=mipsel
BOARD:=au1000
BOARDNAME:=RMI/AMD AU1x00
FEATURES:=squashfs usb pci
-SUBTARGETS=au1500 au1550
+SUBTARGETS:=au1500 au1550
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
KERNEL_PATCHVER:=3.18
diff --git a/target/linux/ixp4xx/Makefile b/target/linux/ixp4xx/Makefile
index 34c81ffe78..a185ce8df5 100644
--- a/target/linux/ixp4xx/Makefile
+++ b/target/linux/ixp4xx/Makefile
@@ -11,7 +11,7 @@ BOARD:=ixp4xx
BOARDNAME:=Intel IXP4xx
FEATURES:=squashfs
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
-SUBTARGETS=generic harddisk
+SUBTARGETS:=generic harddisk
KERNEL_PATCHVER:=4.4
diff --git a/target/linux/lantiq/Makefile b/target/linux/lantiq/Makefile
index af4295cbb8..d3721f6c2c 100644
--- a/target/linux/lantiq/Makefile
+++ b/target/linux/lantiq/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
BOARD:=lantiq
BOARDNAME:=Lantiq
FEATURES:=squashfs
-SUBTARGETS=xrx200 xway xway_legacy
+SUBTARGETS:=xrx200 xway xway_legacy
MAINTAINER:=John Crispin <john@phrozen.org>
KERNEL_PATCHVER:=4.4
diff --git a/target/linux/mpc85xx/Makefile b/target/linux/mpc85xx/Makefile
index 7f986452c5..161c8cb816 100644
--- a/target/linux/mpc85xx/Makefile
+++ b/target/linux/mpc85xx/Makefile
@@ -12,7 +12,7 @@ BOARDNAME:=Freescale MPC85xx
CPU_TYPE:=8540
FEATURES:=squashfs
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
-SUBTARGETS=generic p1020
+SUBTARGETS:=generic p1020
KERNEL_PATCHVER:=4.4
diff --git a/target/linux/x86/Makefile b/target/linux/x86/Makefile
index 218b92487b..d702e4e8a0 100644
--- a/target/linux/x86/Makefile
+++ b/target/linux/x86/Makefile
@@ -10,7 +10,7 @@ ARCH:=i386
BOARD:=x86
BOARDNAME:=x86
FEATURES:=squashfs ext4 vdi vmdk pcmcia targz fpu
-SUBTARGETS=generic legacy xen_domu geode 64
+SUBTARGETS:=generic legacy xen_domu geode 64
MAINTAINER:=Felix Fietkau <nbd@nbd.name>
KERNEL_PATCHVER:=4.4
diff --git a/target/linux/xburst/Makefile b/target/linux/xburst/Makefile
index df499b6d53..2a64b7c46f 100644
--- a/target/linux/xburst/Makefile
+++ b/target/linux/xburst/Makefile
@@ -14,7 +14,7 @@ SUBTARGETS:=qi_lb60
KERNEL_PATCHVER:=3.18
-DEVICE_TYPE=other
+DEVICE_TYPE:=other
define Target/Description
Build firmware images for XBurst JZ47x0 based boards.